summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 001d00e9be..07725c727a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -92,7 +92,9 @@
(sha256
(base32
"1h7zbrf9pkj29hlm18b10548ch9757f75m64l47sy75rh43p7lqw"))
- (patches (list (search-patch "python-2.7-search-paths.patch")))))
+ (patches (map search-patch
+ '("python-2.7-search-paths.patch"
+ "python-2.7-source-date-epoch.patch")))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f
@@ -158,6 +160,11 @@
"Lib/distutils/tests/test_spawn.py"
"Lib/test/test_subprocess.py"))
(("/bin/sh") (which "sh")))
+
+ ;; Use zero as the timestamp in .pyc files so that builds are
+ ;; deterministic. TODO: Remove it when this variable is set in
+ ;; gnu-build-system.scm.
+ (setenv "SOURCE_DATE_EPOCH" "0")
#t))
(add-before
'check 'pre-check