summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm193
1 files changed, 132 insertions, 61 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d46119718b..3f8dea48f5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -135,7 +135,7 @@
(define-public python-2.7
(package
(name "python")
- (version "2.7.13")
+ (version "2.7.14")
(source
(origin
(method url-fetch)
@@ -143,12 +143,12 @@
version "/Python-" version ".tar.xz"))
(sha256
(base32
- "0cgpk3zk0fgpji59pb4zy9nzljr70qzgv1vpz5hq5xw2d2c47m9m"))
+ "0rka541ys16jwzcnnvjp2v12m4cwgd2jp6wj4kj511p715pb5zvi"))
(patches (search-patches "python-2.7-search-paths.patch"
"python-2-deterministic-build-info.patch"
"python-2.7-site-prefixes.patch"
"python-2.7-source-date-epoch.patch"
- "python-2.7-getentropy-on-old-kernels.patch"))
+ "python-2.7-adjust-tests.patch"))
(modules '((guix build utils)))
;; suboptimal to delete failing tests here, but if we delete them in the
;; arguments then we need to make sure to strip out that phase when it
@@ -206,6 +206,7 @@
'("Lib/subprocess.py"
"Lib/popen2.py"
"Lib/distutils/tests/test_spawn.py"
+ "Lib/test/support/__init__.py"
"Lib/test/test_subprocess.py"))
(("/bin/sh") (which "sh")))
@@ -331,28 +332,28 @@ data types.")
;; Current 2.x version.
(define-public python-2 python-2.7)
-(define-public python-3.5
+(define-public python-3.6
(package (inherit python-2)
- (version "3.5.3")
+ (version "3.6.3")
(source (origin
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
version "/Python-" version ".tar.xz"))
(patches (search-patches
"python-fix-tests.patch"
- "python-3.5-fix-tests.patch"
- "python-3.5-getentropy-on-old-kernels.patch"
+ "python-3-fix-tests.patch"
"python-3-deterministic-build-info.patch"
"python-3-search-paths.patch"))
(patch-flags '("-p0"))
(sha256
(base32
- "1c6v1n9nz4mlx9mw1125fxpmbrgniqdbbx9hnqx44maqazb2mzpf"))
+ "1nl1raaagr4car787a2hmjv2dw6gqny53xfd6wisbgx4r5kxk9yd"))
(snippet
'(begin
(for-each delete-file
- '("Lib/ctypes/test/test_win32.py" ; fails on aarch64
- "Lib/test/test_fcntl.py"))
+ '("Lib/ctypes/test/test_structures.py" ; fails on aarch64
+ "Lib/ctypes/test/test_win32.py" ; fails on aarch64
+ "Lib/test/test_fcntl.py")) ; fails on aarch64
#t))))
(arguments (substitute-keyword-arguments (package-arguments python-2)
((#:tests? _) #t)))
@@ -364,7 +365,7 @@ data types.")
"/site-packages"))))))))
;; Current 3.x version.
-(define-public python-3 python-3.5)
+(define-public python-3 python-3.6)
;; Current major version.
(define-public python python-3)
@@ -955,18 +956,24 @@ from the Python interpreter, or as a small part of a larger application.")
(define-public python-six
(package
(name "python-six")
- (version "1.10.0")
+ (version "1.11.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "six" version))
(sha256
(base32
- "0snmb8xffb3vsma0z67i0h0w2g2dy0p3gsgh9gi4i0kgc5l8spqh"))))
+ "1scqzwc51c875z23phj48gircqjgnn3af8zy2izjwmnlxrxsgs3h"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "py.test" "-v")))))))
(native-inputs
`(("python-py" ,python-py)
- ("python-pytest" ,python-pytest)))
+ ("python-pytest" ,python-pytest-bootstrap)))
(home-page "http://pypi.python.org/pypi/six/")
(synopsis "Python 2 and 3 compatibility utilities")
(description
@@ -1250,6 +1257,28 @@ bug tracker.")
(home-page "http://www.liquidx.net/pybugz/")
(license license:gpl2)))
+(define-public python2-enum
+ (package
+ (name "python2-enum")
+ (version "0.4.6")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "enum" version))
+ (sha256
+ (base32
+ "13lk3yrwj42vl30kw3c194f739nrfrdg64s6i0v2p636n4k8brsl"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (home-page "http://pypi.python.org/pypi/enum/")
+ (synopsis "Robust enumerated type support in Python")
+ (description
+ "This provides a module for robust enumerations in Python. It has
+been superseded by the Python standard library and is provided only for
+compatibility.")
+ ;; Choice of either license.
+ (license (list license:gpl3+ license:psfl))))
+
(define-public python-enum34
(package
(name "python-enum34")
@@ -1472,17 +1501,62 @@ matching them against a list of media-ranges.")
"@code{pafy} is a python library to retrieve YouTube content and metadata.")
(license license:lgpl3+)))
+(define-public python2-funcsigs
+ (package
+ (name "python2-funcsigs")
+ (version "1.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "funcsigs" version))
+ (sha256
+ (base32
+ "0l4g5818ffyfmfs1a924811azhjj8ax9xd1cffr1mzd3ycn0zfx7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (native-inputs
+ `(("python2-unittest2" ,python2-unittest2)))
+ (home-page "http://funcsigs.readthedocs.org")
+ (synopsis "Python function signatures from PEP362")
+ (description
+ "Backport of @code{funcsigs} which was introduced in Python 3.3.")
+ (license license:asl2.0)))
+
+(define-public python-pafy
+ (package
+ (name "python-pafy")
+ (version "0.5.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pafy" version))
+ (sha256
+ (base32
+ "1a7dxi95m1043rxx1r5x3ngb66nwlq6aqcasyqqjzmmmjps4zrim"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; Currently pafy can not find itself in the tests
+ (propagated-inputs
+ ;; Youtube-dl is a python package which is imported in the file
+ ;; "backend_youtube_dl.py", therefore it needs to be propagated.
+ `(("youtube-dl" ,youtube-dl)))
+ (home-page "https://np1.github.io/pafy/")
+ (synopsis "Retrieve YouTube content and metadata")
+ (description
+ "@code{pafy} is a python library to retrieve YouTube content and metadata.")
+ (license license:lgpl3+)))
+
(define-public python-py
(package
(name "python-py")
- (version "1.4.32")
+ (version "1.4.34")
(source
(origin
(method url-fetch)
(uri (pypi-uri "py" version))
(sha256
(base32
- "19s1pql9pq85h1qzsdwgyb8a3k1qgkvh33b02m8kfqhizz8rzf64"))))
+ "1qyd5z0hv8ymxy84v5vig3vps2fvhcf4bdlksb3r03h549fmhb8g"))))
(build-system python-build-system)
(arguments
;; FIXME: "ImportError: 'test' module incorrectly imported from
@@ -1852,7 +1926,7 @@ somewhat intelligible.")
#t))))
(build-system python-build-system)
(native-inputs
- `(("python-pytest" ,python-pytest-3.0)
+ `(("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
("python-pytest-runner" ,python-pytest-runner)))
(home-page "https://github.com/progrium/pyjwt")
@@ -2014,18 +2088,6 @@ for Python.")
(base32
"1zzrkywhziqffrzks14kzixz7nd4yh2vc0fb04a68vfd2ai03anx"))))
(build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; These files cannot be built with Python < 3.6. See
- ;; https://github.com/pallets/jinja/issues/655
- ;; FIXME: Remove this when the "python" package is upgraded.
- (add-after 'unpack 'delete-incompatible-files
- (lambda _
- (for-each delete-file
- '("jinja2/asyncsupport.py"
- "jinja2/asyncfilters.py"))
- #t)))))
(propagated-inputs
`(("python-markupsafe" ,python-markupsafe)))
(home-page "http://jinja.pocoo.org/")
@@ -2276,7 +2338,7 @@ sources.")
`(("python-sphinxcontrib-websupport" ,python-sphinxcontrib-websupport)
,@(package-propagated-inputs python-sphinx)))
(native-inputs
- `(("python-pytest" ,python-pytest-3.0)
+ `(("python-pytest" ,python-pytest)
("imagemagick" ,imagemagick) ; for "convert"
,@(package-native-inputs python-sphinx)))
(properties '())))
@@ -2294,7 +2356,7 @@ sources.")
(base32
"0kw1axswbvaavr8ggyf4qr6hnisnrzlbkkcdada69vk1x9xjassg"))))
(native-inputs
- `(("python-pytest" ,python-pytest-3.0)
+ `(("python-pytest" ,python-pytest)
,@(package-native-inputs python-sphinx)))))
(define-public python2-sphinx
@@ -3916,7 +3978,7 @@ Python language binding specification.")
(arguments '(#:tests? #f)) ; Test file 'grako.ebnf' is missing from archive.
(native-inputs
`(("unzip" ,unzip)
- ("python-pytest" ,python-pytest-3.0)
+ ("python-pytest" ,python-pytest)
("python-pytest-runner" ,python-pytest-runner)))
(home-page "https://bitbucket.org/neogeny/grako")
(synopsis "EBNF parser generator")
@@ -3974,7 +4036,7 @@ cluster without needing to write any wrapper code yourself.")
(base32 "0zizn61n5z5hq421hkypk9pw8s6fpxw30f4hsg7k4ivwzy3gjw9j"))))
(build-system python-build-system)
(native-inputs
- `(("python-pytest" ,python-pytest-3.0)
+ `(("python-pytest" ,python-pytest)
("python-mock" ,python-mock)
("python-tox" ,python-tox)
("which" ,which))) ;for tests
@@ -4037,7 +4099,7 @@ displayed.")
(replace 'check (lambda _ (zero? (system* "nosetests" "-v")))))))
(native-inputs
`(("python-nose" ,python-nose)
- ("python-pytest" ,python-pytest-3.0)
+ ("python-pytest" ,python-pytest)
("man-db" ,man-db)
("which" ,which)
("bash-full" ,bash))) ;full Bash for 'test_replwrap.py'
@@ -4058,13 +4120,13 @@ child application and control it as if a human were typing commands.")
(define-public python-setuptools-scm
(package
(name "python-setuptools-scm")
- (version "1.15.0")
+ (version "1.15.6")
(source (origin
(method url-fetch)
(uri (pypi-uri "setuptools_scm" version))
(sha256
(base32
- "0bwyc5markib0i7i2qlyhdzxhiywzxbkfiapldma8m91m82jvwfs"))))
+ "0pzvfmx8s20yrgkgwfbxaspz2x1g38qv61jpm0ns91lrb22ldas9"))))
(build-system python-build-system)
(home-page "https://github.com/pypa/setuptools_scm/")
(synopsis "Manage Python package versions in SCM metadata")
@@ -5117,14 +5179,14 @@ PEP 8.")
(define-public python-pyflakes
(package
(name "python-pyflakes")
- (version "1.0.0")
+ (version "1.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyflakes" version))
(sha256
(base32
- "0qs2sgqszq7wcplis8509wk2ygqcrwzbs1ghfj3svvivq2j377pk"))))
+ "1x1pcca4a24k4pw8x1c77sgi58cg1wl2k38mp8a25k608pzls3da"))))
(build-system python-build-system)
(home-page
"https://github.com/pyflakes/pyflakes")
@@ -5139,17 +5201,17 @@ PEP 8.")
(define-public python-mccabe
(package
(name "python-mccabe")
- (version "0.4.0")
+ (version "0.6.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "mccabe" version))
(sha256
(base32
- "0yr08a36h8lqlif10l4xcikbbig7q8f41gqywir7rrvnv3mi4aws"))))
+ "07w3p1qm44hgxf3vvwz84kswpsx6s7kvaibzrsx5dzm0hli1i3fx"))))
(build-system python-build-system)
(native-inputs
- `(("python-pytest" ,python-pytest)
+ `(("python-pytest" ,python-pytest-bootstrap)
("python-pytest-runner" ,python-pytest-runner)))
(home-page "https://github.com/flintwork/mccabe")
(synopsis "McCabe checker, plugin for flake8")
@@ -5222,39 +5284,48 @@ complexity of Python source code.")
(define-public python-flake8
(package
(name "python-flake8")
- (version "2.5.4")
+ (version "3.4.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "flake8" version))
(sha256
(base32
- "0bs9cz4fr99r2rwig1b8jwaadl1nan7kgpdzqwj0bwbckwbmh7nc"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Remove pre-compiled .pyc files from source.
- (for-each delete-file-recursively
- (find-files "." "__pycache__" #:directories? #t))
- (for-each delete-file (find-files "." "\\.pyc$"))
- #t))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python-pep8" ,python-pep8)
+ "1n0i38592vy3q0x2a9bf8z6rhhn04i30wsn5i5zzcj7qkxvl8062"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (zero? (system* "pytest" "-v")))))))
+ (propagated-inputs
+ `(("python-pycodestyle" ,python-pycodestyle)
("python-pyflakes" ,python-pyflakes)
+ ;; flake8 depends on a newer setuptools than provided by python.
+ ("python-setuptools" ,python-setuptools)
("python-mccabe" ,python-mccabe)))
(native-inputs
`(("python-mock" ,python-mock) ; TODO: only required for < 3.3
- ("python-nose" ,python-nose)))
+ ("python-pytest" ,python-pytest-bootstrap)
+ ("python-pytest-runner" ,python-pytest-runner)))
(home-page "https://gitlab.com/pycqa/flake8")
(synopsis
"The modular source code checker: pep8, pyflakes and co")
(description
"Flake8 is a wrapper around PyFlakes, pep8 and python-mccabe.")
+ (properties `((python2-variant . ,(delay python2-flake8))))
(license license:expat)))
(define-public python2-flake8
- (package-with-python2 python-flake8))
+ (let ((base (package-with-python2 (strip-python2-variant python-flake8))))
+ (package (inherit base)
+ (propagated-inputs
+ `(("python2-configparser" ,python2-configparser)
+ ("python2-enum" ,python2-enum)
+ ,@(package-propagated-inputs base))))))
(define-public python-flake8-polyfill
(package
@@ -11284,7 +11355,7 @@ address is valid and really exists.")
`(("python-dateutil" ,python-dateutil)
("python-simplejson" ,python-simplejson)))
(native-inputs
- `(("python-pytest-3.0" ,python-pytest-3.0)
+ `(("python-pytest" ,python-pytest)
("python-pytz" ,python-pytz)))
(home-page "https://github.com/marshmallow-code/marshmallow")
(synopsis "Convert complex datatypes to and from native
@@ -11311,7 +11382,7 @@ complex datatypes to and from native Python datatypes.")
(propagated-inputs
`(("python-pyyaml" ,python-pyyaml)))
(native-inputs
- `(("python-pytest-3.0" ,python-pytest-3.0)
+ `(("python-pytest" ,python-pytest)
("python-flask" ,python-flask)
("python-marshmallow" ,python-marshmallow)
("python-tornado" ,python-tornado)
@@ -11364,7 +11435,7 @@ Swagger 2.0).")
("python-flake8" ,python-flake8)
("python-flask-restful" ,python-flask-restful)
("python-flex" ,python-flex)
- ("python-pytest-3.0" ,python-pytest-3.0)
+ ("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
("python-marshmallow" ,python-marshmallow)
("python-apispec" ,python-apispec)))
@@ -11746,7 +11817,7 @@ their files and supports any packaging format (including wheels).")
`(;; The tests depend on unittest2, and our version is a bit too old.
#:tests? #f))
(native-inputs
- `(("python-pbr" ,python-pbr)))
+ `(("python-pbr" ,python-pbr-minimal)))
(home-page
"https://github.com/testing-cabal/linecache2")
(synopsis "Backports of the linecache module")
@@ -11775,7 +11846,7 @@ lines are read from a single file.")
`(;; python-traceback2 and python-unittest2 depend on one another.
#:tests? #f))
(native-inputs
- `(("python-pbr" ,python-pbr)))
+ `(("python-pbr" ,python-pbr-minimal)))
(propagated-inputs
`(("python-linecache2" ,python-linecache2)))
(home-page