summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3414ad959b..62494bea20 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -373,7 +373,8 @@ data types.")
"python-3-fix-tests.patch"
"python-3.8-fix-tests.patch"
"python-3-deterministic-build-info.patch"
- "python-3-search-paths.patch"))
+ "python-3-search-paths.patch"
+ "python-3-hurd-configure.patch"))
(sha256
(base32
"1c43dbv9lvlp3ynqmgdi4rh8q94swanhqarqrdx62zmigpakw073"))
@@ -401,17 +402,6 @@ data types.")
,@(if (hurd-system?)
`((delete 'patch-regen-for-hurd)) ;regen was removed after 3.5.9
'())
- ,@(if (hurd-target?)
- ;; The build system refuses to cross-compile for unknown targets
- ;; even though it works fine. Add GNU/Hurd target.
- ;; TODO: Make it a patch in a future rebuild cycle.
- '((add-before 'configure 'support-hurd-cross-compile
- (lambda _
- (substitute* "configure"
- (("\\*-\\*-vxworks.*" all)
- (string-append "*-*-gnu)\nac_sys_system=GNU\n;;\n" all)))
- #t)))
- '())
(add-before 'check 'set-TZDIR
(lambda* (#:key inputs native-inputs #:allow-other-keys)
;; test_email requires the Olson time zone database.