summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9d97050c66..e05c91b3d0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -107,6 +107,7 @@
(define-public python-2.7
(package
(name "python2")
+ (replacement python-2.7/fixed)
(version "2.7.17")
(source
(origin
@@ -350,6 +351,14 @@ data types.")
(properties '((cpe-name . "python")))
(license license:psfl)))
+(define python-2.7/fixed
+ (package
+ (inherit python-2.7)
+ (source (origin
+ (inherit (package-source python-2.7))
+ (patches (append (search-patches "python-2.7-CVE-2021-3177.patch")
+ (origin-patches (package-source python-2.7))))))))
+
;; Current 2.x version.
(define-public python-2 python-2.7)