summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index feb211edb8..6132019a53 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10200,7 +10200,14 @@ cyclomatic complexity of Python source code.")
(uri (pypi-uri "flake8" version))
(sha256
(base32
- "0sspgh2ph7bb5fmf49mrdhi7n5m421kfkxk1n0vn4akgg20q6lh7"))))
+ "0sspgh2ph7bb5fmf49mrdhi7n5m421kfkxk1n0vn4akgg20q6lh7"))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ (substitute* "setup.cfg"
+ ;; Remove upper bound on pyflakes version.
+ (("(pyflakes >=.*), .*" _ pyflakes)
+ (string-append pyflakes "\n")))))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases