summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b1a2ab5efd..af557fd009 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7590,16 +7590,11 @@ multiprecision arithmetic.")
(arguments
`(#:phases
(modify-phases %standard-phases
- ;; Run the core tests after installation. By default it would run
- ;; *all* tests, which take a very long time to complete and are known
- ;; to be flaky.
- (delete 'check)
- (add-after 'install 'check
+ (replace 'check
(lambda* (#:key outputs #:allow-other-keys)
(invoke
(or (which "python3") (which "python"))
- "-c" "import sympy; sympy.test(\"/core\")")
- #t)))))
+ "-c" "import sympy; sympy.test(\"/core\")"))))))
(propagated-inputs
`(("python-mpmath" ,python-mpmath)))
(home-page "https://www.sympy.org/")