summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm218
1 files changed, 92 insertions, 126 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 37cce63eba..a995618305 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26,7 +26,7 @@
;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
-;;; Copyright © 2016, 2017, 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016, 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
;;; Copyright © 2016, 2017 Alex Vong <alexvong1995@gmail.com>
@@ -302,7 +302,14 @@ by @code{binstar}, @code{binstar-build} and @code{chalmers}.")
(arguments
`(#:phases (modify-phases %standard-phases
(replace 'check
- (lambda _ (invoke "pytest" "-vv"))))))
+ (lambda _
+ (invoke "pytest" "-vv" "-k"
+ (string-append
+ ;; XXX: These tests fail when using Pytest 4.x and
+ ;; Babel 2.6.0. Try removing this for later versions.
+ "not test_no_inherit_metazone_marker_never_in_output"
+ " and not test_smoke_dates"
+ " and not test_smoke_numbers")))))))
(home-page "http://babel.pocoo.org/")
(synopsis
"Tools for internationalizing Python applications")
@@ -614,14 +621,14 @@ encoded).")
(define-public python-setuptools
(package
(name "python-setuptools")
- (version "40.0.0")
+ (version "40.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "setuptools" version ".zip"))
(sha256
(base32
- "0pq116lr14gnc62v76nk0npkm6krb2mpp7p9ab369zgv4n7dnah1"))
+ "0k9hifpgahnw2a26w3cr346iy733k6d3nwh3f7g9m13y6f8fqkkf"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -872,14 +879,14 @@ from the Python interpreter, or as a small part of a larger application.")
(define-public python-six
(package
(name "python-six")
- (version "1.11.0")
+ (version "1.12.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "six" version))
(sha256
(base32
- "1scqzwc51c875z23phj48gircqjgnn3af8zy2izjwmnlxrxsgs3h"))))
+ "0wxs1q74v07ssjywbbm7x6h5v9qx209ld2yfsif4060sxi0h2sni"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1529,14 +1536,14 @@ server.")
(define-public python-py
(package
(name "python-py")
- (version "1.5.4")
+ (version "1.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "py" version))
(sha256
(base32
- "1xxvwfn82457djf55f5n2c94699rfqnk43br8fif2r2q8gvrmm9z"))))
+ "0lsy1gajva083pzc7csj1cvbmminb7b4l6a0prdzyb3fd829nqyw"))))
(build-system python-build-system)
(arguments
;; FIXME: "ImportError: 'test' module incorrectly imported from
@@ -1983,13 +1990,13 @@ JavaScript-like message boxes. Types of dialog boxes include:
(package
(name "python-pympler")
(home-page "https://pythonhosted.org/Pympler/")
- (version "0.5")
+ (version "0.6")
(source (origin
(method url-fetch)
(uri (pypi-uri "Pympler" version))
(sha256
(base32
- "03qwsbilqgvnbl3a1jmpgixbr2kq6m3fvdlzyr3wdp01bwlc85kx"))))
+ "19qkpaw5icwhb4c0f6ijqfmhwhj34k2k6s4m4fsvhrxc9p5cwqn2"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -3775,14 +3782,14 @@ as the original project seems to have been abandoned circa 2007.")
(define-public python-pycodestyle
(package
(name "python-pycodestyle")
- (version "2.4.0")
+ (version "2.5.0")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pycodestyle" version))
- (sha256
- (base32
- "0fhy4vnlgpjq4qd1wdnl6pvdw7rah0ypmn8c9mkhz8clsndskz6b"))))
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pycodestyle" version))
+ (sha256
+ (base32
+ "0v4prb05n21bm8650v0a01k1nyqjdmkrsm3zycfxh2j5k9n962p4"))))
(build-system python-build-system)
(home-page "https://pycodestyle.readthedocs.io/")
(synopsis "Python style guide checker")
@@ -4444,13 +4451,13 @@ child application and control it as if a human were typing commands.")
(define-public python-setuptools-scm
(package
(name "python-setuptools-scm")
- (version "3.1.0")
+ (version "3.2.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "setuptools_scm" version))
(sha256
(base32
- "0h4bglwfz8b9prqljv8z3w9rgydfyxzaj05bm1y6zs5m6shz548i"))))
+ "0n3knn3p1sqlx31k2lahn7z9bacvlv8nhlfidj77vz50bxqlgasj"))))
(build-system python-build-system)
(home-page "https://github.com/pypa/setuptools_scm/")
(synopsis "Manage Python package versions in SCM metadata")
@@ -5666,14 +5673,14 @@ PEP 8.")
(define-public python-pyflakes
(package
(name "python-pyflakes")
- (version "2.0.0")
+ (version "2.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyflakes" version))
(sha256
(base32
- "0jba28czyvimdc72llms3f17swp3i8jdcabf5w0j00adfbn64xls"))))
+ "18pq95a1xj2dgdd0m85gyfsn40jajj4xc3lp8wfv7igqhrc86xnr"))))
(build-system python-build-system)
(home-page
"https://github.com/pyflakes/pyflakes")
@@ -5762,35 +5769,20 @@ complexity of Python source code.")
(define-public python2-pyflakes-0.8.1
(package-with-python2 python-pyflakes-0.8.1))
-;; This package is used by hypothesis which has thousands of dependent packages.
-;; FIXME: Consolidate this with "python-flake8" below in the next rebuild cycle.
-(define-public python-flake8-3.5
+(define-public python-flake8
(package
(name "python-flake8")
- (version "3.5.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "flake8" version))
- (sha256
- (base32
- "184b33grvvjmiwlv9kyd7yng9qv5ld24154j70z332xxg9gjclvj"))))
+ (version "3.7.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8" version))
+ (sha256
+ (base32
+ "0qg6zggqigrd4k3gv88shd1a27d0cwgfql8vfiq2c7rl7w3rd6c5"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- ;; Two errors don't seem to have assigned codes.
- (add-after 'unpack 'delete-broken-test
- (lambda _ (delete-file "tests/unit/test_pyflakes_codes.py") #t))
- (add-after 'unpack 'fix-problem-with-pycodestyle
- (lambda _
- ;; See https://gitlab.com/pycqa/flake8/merge_requests/230
- ;; This should no longer be needed with the next release.
- (substitute* "setup.py"
- (("PEP8_PLUGIN\\('break_around_binary_operator'\\),")
- "PEP8_PLUGIN('break_after_binary_operator'),\
-PEP8_PLUGIN('break_before_binary_operator'),"))
- #t))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -5799,6 +5791,7 @@ PEP8_PLUGIN('break_before_binary_operator'),"))
#t)))))
(propagated-inputs
`(("python-pycodestyle" ,python-pycodestyle)
+ ("python-entrypoints" ,python-entrypoints)
("python-pyflakes" ,python-pyflakes)
("python-mccabe" ,python-mccabe)))
(native-inputs
@@ -5810,45 +5803,18 @@ PEP8_PLUGIN('break_before_binary_operator'),"))
"The modular source code checker: pep8, pyflakes and co")
(description
"Flake8 is a wrapper around PyFlakes, pep8 and python-mccabe.")
- (properties `((python2-variant . ,(delay python2-flake8-3.5))))
+ (properties `((python2-variant . ,(delay python2-flake8))))
(license license:expat)))
-(define-public python2-flake8-3.5
- (let ((base (package-with-python2 (strip-python2-variant python-flake8-3.5))))
+(define-public python2-flake8
+ (let ((base (package-with-python2 (strip-python2-variant python-flake8))))
(package (inherit base)
(propagated-inputs
`(("python2-configparser" ,python2-configparser)
("python2-enum34" ,python2-enum34)
+ ("python2-typing" ,python2-typing)
,@(package-propagated-inputs base))))))
-;; Version 3.5.0 has compatibility issues with Pyflakes 2.0, so we need
-;; this newer version. Keep it as a separate variable for now to avoid
-;; rebuilding "python-hypothesis"; this should be removed in the next
-;; rebuild cycle.
-(define-public python-flake8
- (package
- (inherit python-flake8-3.5)
- (version "3.6.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "flake8" version))
- (sha256
- (base32
- "0w0nprx22rbvrrkbfx9v5jc5gskbm08g219l7r8wai8zfswgadba"))))
- (arguments
- (substitute-keyword-arguments (package-arguments python-flake8-3.5)
- ((#:phases phases)
- `(modify-phases ,phases
- (delete 'delete-broken-test)
- (delete 'fix-problem-with-pycodestyle)))))
- (properties `((python2-variant . ,(delay python2-flake8))))))
-
-(define-public python2-flake8
- (let ((base (package-with-python2 (strip-python2-variant python-flake8))))
- (package (inherit base)
- (propagated-inputs
- (package-propagated-inputs python2-flake8-3.5)))))
-
;; python-hacking requires flake8 <2.6.0.
(define-public python-flake8-2.5
(package
@@ -6076,13 +6042,13 @@ add functionality and customization to your projects with their own plugins.")
(define-public python-fonttools
(package
(name "python-fonttools")
- (version "3.28.0")
+ (version "3.38.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "fonttools" version ".zip"))
(sha256
(base32
- "0vsvjhidpb5kywpjgz1j3fywzkddxkb0afqai18qa3h6lqjyxwpb"))))
+ "12ripk3s7skgxr1bs9r8n13r94ym3s8iir7ivfixls9fa4dabmlh"))))
(build-system python-build-system)
(native-inputs
`(("unzip" ,unzip)
@@ -7194,6 +7160,8 @@ simulation, statistical modeling, machine learning and much more.")
("python-pytest" ,python-pytest)
("python-pytest-runner" ,python-pytest-runner)))
(build-system python-build-system)
+ ;; XXX: Incompatible with Pytest 4: <https://github.com/chardet/chardet/issues/173>.
+ (arguments `(#:tests? #f))
(home-page "https://github.com/chardet/chardet")
(synopsis "Universal encoding detector for Python 2 and 3")
(description
@@ -7419,13 +7387,13 @@ tables.")
(define-public python-atomicwrites
(package
(name "python-atomicwrites")
- (version "1.1.5")
+ (version "1.3.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "atomicwrites" version))
(sha256
(base32
- "11bm90fwm2avvf4f3ib8g925w7jr4m11vcsinn1bi6ns4bm32214"))))
+ "19ngcscdf3jsqmpcxn6zl5b6anmsajb6izp1smcd1n02midl9abm"))))
(build-system python-build-system)
(synopsis "Atomic file writes in Python")
(description "Library for atomic file writes using platform dependent tools
@@ -7758,11 +7726,14 @@ otherwise matches 3.2’s API.")
(base32
"0rdjmmsab550kxsssdq49jcniz77zlkpw4pvi9hvib3lsskjmh4y"))))
(build-system python-build-system)
- (arguments `(#:python ,python-2
- ;; FIXME: Python 2.7.14 moved the test.support library,
- ;; but our package has not yet been adjusted. Enable
- ;; tests when the python2 package has been fixed.
- #:tests? #f))
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "test_futures.py")
+ #t)))))
(home-page "https://github.com/agronholm/pythonfutures")
(synopsis
"Backport of the concurrent.futures package from Python 3.2")
@@ -7854,14 +7825,14 @@ library as well as on the command line.")
(define-public python-pluggy
(package
(name "python-pluggy")
- (version "0.7.1")
+ (version "0.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pluggy" version))
(sha256
(base32
- "1qbn70mksmr03hac6jgp6fiqc4l7859z8dchx2x950vhlij87swm"))))
+ "13yg2q0wgcb4l8lgdvcnzqa8db5lrw3nwn50lxjy1z5jkp7gkv0r"))))
(build-system python-build-system)
(native-inputs
`(("python-setuptools-scm" ,python-setuptools-scm)))
@@ -8022,6 +7993,14 @@ python-xdo for newer bindings.)")
(base32
"1bi5gnr8r8dva06qpyx4kgjc6spm2k1y908183nbbaylggjzs0jf"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-setup.cfg
+ (lambda _
+ ;; Adjust setup.cfg for compatibility with Pytest 4.
+ (substitute* "setup.cfg"
+ (("\\[pytest\\]") "[tool:pytest]"))
+ #t)))))
(propagated-inputs
`(("python-markupsafe" ,python-markupsafe)))
(native-inputs
@@ -8544,13 +8523,13 @@ anymore.")
(define-public python2-pathlib2
(package
(name "python2-pathlib2")
- (version "2.3.2")
+ (version "2.3.3")
(source (origin
(method url-fetch)
(uri (pypi-uri "pathlib2" version))
(sha256
(base32
- "10yb0iv5x2hs631rcppkhbddx799d3h8pcwmkbh2a66ns3w71ccf"))))
+ "0hpp92vqqgcd8h92msm9slv161b1q160igjwnkf2ag6cx0c96695"))))
(build-system python-build-system)
;; We only need the the Python 2 variant, since for Python 3 our minimum
;; version is 3.4 which already includes this package as part of the
@@ -11241,13 +11220,13 @@ and bit flag values.")
(define-public python-attrs
(package
(name "python-attrs")
- (version "18.2.0")
+ (version "19.1.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "attrs" version))
(sha256
(base32
- "0s9ydh058wmmf5v391pym877x4ahxg45dw6a0w4c7s5wgpigdjqh"))))
+ "16g33zr5f449lqc5wgvzpknxryfzrfsxcr6kpgxwn7l5fkv71f7h"))))
(build-system python-build-system)
(arguments
`(#:modules ((guix build utils)
@@ -11289,15 +11268,6 @@ protocols.")
(package
(inherit python-attrs)
(name "python-attrs-bootstrap")
- ;; Keep this on a fixed version so python-attrs can be updated without
- ;; triggering a mass-rebuild. FIXME: Update this in the next rebuild cycle.
- (version "17.4.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "attrs" version))
- (sha256
- (base32
- "1jafnn1kzd6qhxgprhx6y6ik1r5m2rilx25syzcmq03azp660y8w"))))
(native-inputs `())
(arguments `(#:tests? #f))))
@@ -11597,17 +11567,14 @@ of @code{functools.lru_cache} from python 3.3.")
(define-public python-configparser
(package
(name "python-configparser")
- (version "3.5.0")
+ (version "3.7.1")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://bitbucket.org/ambv/configparser/get/"
- version ".tar.bz2"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (pypi-uri "configparser" version))
(sha256
(base32
- "0waq40as14abwzbb321hfz4vr1fi363nscy32ga14qvfygrg96wa"))))
+ "0cnz213il9lhgda6x70fw7mfqr8da43s3wm343lwzhqx94mgmmav"))))
(build-system python-build-system)
(home-page "https://github.com/jaraco/configparser/")
(synopsis "Backport of configparser from python 3.5")
@@ -11984,14 +11951,14 @@ several utilities, as well as an API for building localization tools.")
(define-public python-packaging
(package
(name "python-packaging")
- (version "18.0")
+ (version "19.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "packaging" version))
(sha256
(base32
- "01wq9c53ix5rz6qg2c98gy8n4ff768rmanifm8m5jpjiaizj51h8"))))
+ "1brjhygq9dz6x1kdljivkjfldi3qf5rbkqgck1bpgv9qpv8ab60c"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -13870,41 +13837,40 @@ file system events on Linux.")
(define-public python-more-itertools
(package
(name "python-more-itertools")
- (version "4.3.0")
+ (version "6.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "more-itertools" version))
(sha256
(base32
- "17h3na0rdh8xq30w4b9pizgkdxmm51896bxw600x84jflg9vaxn4"))))
+ "1lfrx2ndnilla3a5lhpjc1wjgkplkxrhp5nyn6ys2l93jkil802r"))))
(build-system python-build-system)
- (arguments
- `(,@(if (any (cute string-prefix? <> (or (%current-system)
- (%current-target-system)))
- '("armhf" "i686"))
- '(#:phases
- (modify-phases %standard-phases
- ;; This is required for 32-bit hardware.
- ;; TODO: Try to remove this when upgrading.
- (add-after 'unpack 'patch-test
- (lambda _
- (substitute* "more_itertools/tests/test_more.py"
- (("10 \\*\\* 10") "9 ** 9"))
- #t))))
- '())))
- (propagated-inputs
- `(("python-six" ,python-six-bootstrap)))
(home-page "https://github.com/erikrose/more-itertools")
(synopsis "More routines for operating on iterables, beyond itertools")
(description "Python's built-in @code{itertools} module implements a
number of iterator building blocks inspired by constructs from APL, Haskell,
and SML. @code{more-itertools} includes additional building blocks for
working with iterables.")
+ (properties `((python2-variant . ,(delay python2-more-itertools))))
(license license:expat)))
+;; The 5.x series are the last versions supporting Python 2.7.
(define-public python2-more-itertools
- (package-with-python2 python-more-itertools))
+ (package
+ (inherit python-more-itertools)
+ (name "python2-more-itertools")
+ (version "5.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "more-itertools" version))
+ (sha256
+ (base32
+ "1r12cm6mcdwdzz7d47a6g4l437xsvapdlgyhqay3i2nrlv03da9q"))))
+ (arguments
+ `(#:python ,python2-minimal))
+ (propagated-inputs
+ `(("python2-six" ,python2-six-bootstrap)))))
(define-public python-latexcodec
(package