summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0fe436cbe5..72d144fdcf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8306,8 +8306,16 @@ cluster down and deletes the throwaway profile.")
(sha256
(base32 "1r6rz8jgrqzhkf2flwjw75d96g8l7kykmx5wli3q1988w96391ip"))))
(build-system python-build-system)
- ;; Tests must run under IPython.
- (arguments '(#:tests? #f))
+ (arguments
+ (list #:tests? #f ;must run under IPython
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'permit-newer-prettytable
+ ;; See https://github.com/catherinedevlin/ipython-sql/issues/202
+ (lambda _
+ (substitute* "setup.py"
+ (("prettytable<1")
+ "prettytable")))))))
(propagated-inputs
(list python-ipython
python-ipython-genutils