summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm57
1 files changed, 0 insertions, 57 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0435b2c7f4..d59d353009 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1843,63 +1843,6 @@ facilitate packaging Python projects, where packaging includes:
(license (list license:psfl ;setuptools itself
license:expat ;six, appdirs, pyparsing
license:asl2.0 ;packaging is dual ASL2/BSD-2
- license:bsd-2))
- (properties `((python2-variant . ,(delay python2-setuptools))))))
-
-;; Newer versions of setuptools no longer support Python 2.
-(define-public python2-setuptools
- (package
- (name "python2-setuptools")
- (version "41.0.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "setuptools" version ".zip"))
- (sha256
- (base32
- "04sns22y2hhsrwfy1mha2lgslvpjsjsz8xws7h2rh5a7ylkd28m2"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Remove included binaries which are used to build self-extracting
- ;; installers for Windows.
- ;; TODO: Find some way to build them ourself so we can include them.
- (for-each delete-file (find-files "setuptools" "^(cli|gui).*\\.exe$"))
- #t))))
- (build-system python-build-system)
- ;; FIXME: Tests require pytest, which itself relies on setuptools.
- ;; One could bootstrap with an internal untested setuptools.
- (arguments
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'compatibility-fixes
- (lambda _
- ;; HTMLParser no longer exists.
- (substitute* "setuptools/py33compat.py"
- (("html_parser.HTMLParser\\(\\).unescape")
- "html.unescape"))
- ;; This needs distutils.msvc9compiler
- (delete-file "setuptools/tests/test_msvc.py"))))))
- (native-inputs
- (list unzip))
- (home-page "https://pypi.org/project/setuptools/")
- (synopsis
- "Library designed to facilitate packaging Python projects")
- (description
- "Setuptools is a fully-featured, stable library designed to facilitate
-packaging Python projects, where packaging includes:
-Python package and module definitions,
-distribution package metadata,
-test hooks,
-project installation,
-platform-specific details,
-Python 3 support.")
- ;; TODO: setuptools now bundles the following libraries:
- ;; packaging, pyparsing, six and appdirs. How to unbundle?
- (license (list license:psfl ; setuptools itself
- license:expat ; six, appdirs, pyparsing
- license:asl2.0 ; packaging is dual ASL2/BSD-2
license:bsd-2))))
(define-public python-setuptools-declarative-requirements