summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm37
1 files changed, 0 insertions, 37 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dba156eaa8..31c597a859 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14401,43 +14401,6 @@ to the Python ecosystem.")
3.2.3 for use with older versions of Python and PyPy.")
(license license:expat)))
-(define-public python2-subprocess32
- (package
- (name "python2-subprocess32")
- (version "3.2.7")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "subprocess32" version))
- (sha256
- (base32
- "14350dhhlhyz5gqzi3lihn9m6lvskx5mcb20srx1kgsk9i50li8y"))
- (patches
- (search-patches "python2-subprocess32-disable-input-test.patch"))))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- ;; The test suite fails with Python > 2.7.13:
- ;; import test.support
- ;; ImportError: No module named support
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-/bin/sh
- (lambda _
- (substitute* '("subprocess32.py"
- "test_subprocess32.py")
- (("/bin/sh") (which "sh")))
- #t)))))
- (home-page "https://github.com/google/python-subprocess32")
- (synopsis "Backport of the subprocess module from Python 3.2")
- (description
- "This is a backport of the @code{subprocess} standard library module
-from Python 3.2 and 3.3 for use on Python 2. It includes bugfixes and some
-new features. On POSIX systems it is guaranteed to be reliable when used
-in threaded applications. It includes timeout support from Python 3.3 but
-otherwise matches 3.2’s API.")
- (license license:psfl)))
-
(define-public python-promise
(package
(name "python-promise")