summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm84
1 files changed, 38 insertions, 46 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 05aa54c09c..5d90133cb2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -521,13 +521,13 @@ with Python's logging module that outputs records using terminal colors.")
(define-public python-pyprind
(package
(name "python-pyprind")
- (version "2.11.2")
+ (version "2.11.3")
(source (origin
(method url-fetch)
(uri (pypi-uri "PyPrind" version))
(sha256
(base32
- "0xg6m5hr33h9bdlrr42kc58jm2m87a9zsagy7n2m4n407d2snv64"))))
+ "1gscnlvj37m421ch3akm3kddxqkrgbg5zrpwy2ky1j59w6vclzg3"))))
(build-system python-build-system)
(propagated-inputs
`(("python-psutil" ,python-psutil)))
@@ -2202,7 +2202,7 @@ human-friendly syntax.")
(define-public python-scour
(package
(name "python-scour")
- (version "038.1")
+ (version "0.38.2")
(source
(origin
(method git-fetch)
@@ -2213,7 +2213,7 @@ human-friendly syntax.")
(string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0rgiypb9ig8x4rl3hfzpy7kwnx1q3064nvlrv4fk0dnp84girn0v"))))
+ (base32 "0mmfvx4wqp8gkpv0kbih89zfs9njvmd3v4dxfqii62xddpxq0f1k"))))
(propagated-inputs
`(("python-six" ,python-six)))
(build-system python-build-system)
@@ -5247,14 +5247,13 @@ humans, and implementation simplicity.")
(define-public python-pdftotext
(package
(name "python-pdftotext")
- (version "2.1.5")
+ (version "2.1.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pdftotext" version))
(sha256
- (base32
- "19la1cw1hmkcr8big04gm2dd5fw0y0z97g930aiy29s1gaqbiblq"))))
+ (base32 "1555wbgr5spj8xflrs4mwsrdmba2f9s72nk50xzqk9ghxaxdvy6a"))))
(build-system python-build-system)
(inputs
`(("poppler" ,poppler)))
@@ -6115,13 +6114,13 @@ the OleFileIO module from PIL, the Python Image Library.")
(define-public python-pikepdf
(package
(name "python-pikepdf")
- (version "2.12.0")
+ (version "2.12.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pikepdf" version))
(sha256
- (base32 "1fgk93v5zac38ak00nw94mi44z9701kn20dkdfpwqr3588vnxfzw"))))
+ (base32 "1si1x4dc4i4ghyirjfws1zkgiwk8kypnpp4gf68haascrdy7znqw"))))
(build-system python-build-system)
(arguments
`(#:tests? #false)) ;require python-xmp-toolkit
@@ -10099,13 +10098,13 @@ designed to efficiently cope with extremely large amounts of data.")
(define-public python-sniffio
(package
(name "python-sniffio")
- (version "1.1.0")
+ (version "1.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sniffio" version))
(sha256
- (base32 "08bsp2pp2dxzn9yzcafwzw8jlm0jf50as0ix8vfhxzk91w810f4f"))))
+ (base32 "1pnkvi6wvn4qd37y69n1ls6n8l63gfmn3pvb1jb50gqxxkn6wrn4"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -16742,9 +16741,9 @@ protocols.")
(define-public python2-attrs-bootstrap
(package-with-python2 python-attrs-bootstrap))
-(define-public python2-cliapp
+(define-public python-cliapp
(package
- (name "python2-cliapp")
+ (name "python-cliapp")
(version "1.20180812.1")
(source
(origin
@@ -16757,35 +16756,27 @@ protocols.")
"1c1jlblbns8qhiaqjpg4xi6lip8xwfc5w643p43rg543havaj45x"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- ;; check phase needs to be run before the build phase. If not,
- ;; coverage-test-runner looks for tests for the built source files,
- ;; and fails.
- (delete 'check)
- (add-before 'build 'check
- (lambda _
- ;; Disable python3 tests
- (substitute* "check"
- (("python3") "# python3"))
- (invoke "./check"))))))
+ `(;; XXX: The tests only do style and coverage checks, which
+ ;; fails due to deprecation warnings, etc.
+ #:tests? #f))
(native-inputs
- `(("python2-coverage-test-runner" ,python2-coverage-test-runner)
- ("python2-pep8" ,python2-pep8)))
+ `(("python-coverage-test-runner" ,python-coverage-test-runner)
+ ("python-pep8" ,python-pep8)))
(propagated-inputs
- `(("python2-pyaml" ,python2-pyaml)))
+ `(("python-pyaml" ,python-pyaml)))
(home-page "https://liw.fi/cliapp/")
(synopsis "Python framework for command line programs")
- (description "@code{python2-cliapp} is a python framework for
-command line programs. It contains the typical stuff such programs
-need to do, such as parsing the command line for options, and
-iterating over input files.")
+ (description "@code{cliapp} is a Python framework for command line
+programs. It contains the typical stuff such programs need to do, such
+as parsing the command line for options, and iterating over input files.")
(license license:gpl2+)))
-(define-public python2-ttystatus
+(define-public python2-cliapp
+ (package-with-python2 python-cliapp))
+
+(define-public python-ttystatus
(package
- (name "python2-ttystatus")
+ (name "python-ttystatus")
(version "0.38")
(source
(origin
@@ -16799,11 +16790,10 @@ iterating over input files.")
(file-name (git-file-name name version))))
(build-system python-build-system)
(native-inputs
- `(("python2-coverage-test-runner" ,python2-coverage-test-runner)
- ("python2-pep8" ,python2-pep8)))
+ `(("python-coverage-test-runner" ,python-coverage-test-runner)
+ ("python-pep8" ,python-pep8)))
(arguments
- `(#:python ,python-2
- #:phases
+ `(#:phases
(modify-phases %standard-phases
;; check phase needs to be run before the build phase. If not,
;; coverage-test-runner looks for tests for the built source files,
@@ -16814,13 +16804,15 @@ iterating over input files.")
(home-page "https://liw.fi/ttystatus/")
(synopsis "Python library for showing progress reporting and
status updates on terminals")
- (description "@code{python2-ttystatus} is a python library for
-showing progress reporting and status updates on terminals, for
-command line programs. Output is automatically adapted to the width
-of the terminal: truncated if it does not fit, and resized if the
-terminal size changes.")
+ (description "@code{ttystatus} is a Python library for showing progress
+reporting and status updates on terminals, for command line programs.
+Output is automatically adapted to the width of the terminal: truncated
+if it does not fit, and resized if the terminal size changes.")
(license license:gpl3+)))
+(define-public python2-ttystatus
+ (package-with-python2 python-ttystatus))
+
(define-public python2-tracing
(package
(name "python2-tracing")
@@ -20400,7 +20392,7 @@ user-space file systems in Python.")
(define-public pybind11
(package
(name "pybind11")
- (version "2.6.1")
+ (version "2.6.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -20408,7 +20400,7 @@ user-space file systems in Python.")
(commit (string-append "v" version))))
(sha256
(base32
- "1wh5b1xnywzxwxkyac2wvyqwzmy1qxs341jjk820r7b825wn6yad"))
+ "1lsacpawl2gb5qlh0cawj9swsyfbwhzhwiv6553a7lsigdbadqpy"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(native-inputs