summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 193c86ac48..7a522853ff 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8812,13 +8812,11 @@ SVG, EPS, PNG and terminal output.")
`(#:phases
(modify-phases %standard-phases
(add-before 'check 'start-xserver
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xorg-server (assoc-ref inputs "xorg-server")))
- ;; There must be a running X server and make check doesn't
- ;; start one. Therefore we must do it.
- (system (format #f "~a/bin/Xvfb :1 &" xorg-server))
- (setenv "DISPLAY" ":1")
- #t)))
+ (lambda _
+ ;; There must be a running X server and make check doesn't
+ ;; start one. Therefore we must do it.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?