summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 0 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9b78bee8e2..d3e3da4e05 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17608,17 +17608,6 @@ JSON) codec.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-before 'check 'patch-Makefile
- ;; Stricly this is only required for the python2 variant.
- ;; But adding a phase in an inherited package seems to be
- ;; cumbersum. So we patch even for python3.
- (lambda _
- (let ((nose (assoc-ref %build-inputs "python2-nose")))
- (when nose
- (substitute* "Makefile"
- (("\\$\\(PYTHON\\) [^ ]which nosetests[^ ] ")
- (string-append nose "/bin/nosetests "))))
- #t)))
(replace 'check
(lambda _
(setenv "PYTHON" (or (which "python3") (which "python")))