summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 97eb3651a5..e86be67ddb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30677,6 +30677,10 @@ writing STL files. It supports both the text and binary forms of STL.")
;; There is a bug in the test_suit specification.
(add-after 'unpack 'patch-test-suite
(lambda _
+ ;; Make compatible with PyYAML 6.
+ (substitute* "multipart/tests/test_multipart.py"
+ (("yaml.load")
+ "yaml.safe_load"))
(substitute* "setup.py"
(("test_suite = 'multipart.tests.suite'")
"test_suite = 'multipart.tests.test_multipart.suite'"))