summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8d12f28850..8b55e67ca9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30183,12 +30183,14 @@ Python @code{set} interface.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-for-click-8
+ (lambda _
+ (substitute* "dynaconf/cli.py"
+ (("click.get_os_args\\()") ;deprecated from Click 8.1+
+ "sys.argv[1:]"))))
(replace 'check
(lambda* (#:key tests? outputs #:allow-other-keys)
(when tests?
- (setenv "PATH"
- (string-append (assoc-ref outputs "out") "/bin:"
- (getenv "PATH")))
;; These tests depend on hvac and a live Vault process.
(delete-file "tests/test_vault.py")
(invoke "make" "test_only")))))))
@@ -30196,7 +30198,7 @@ Python @code{set} interface.")
(list python-click python-configobj python-dotenv-0.13.0
python-ruamel.yaml python-toml))
(native-inputs
- (list python-django python-flask python-pytest-6 python-pytest-cov
+ (list python-django python-flask python-pytest python-pytest-cov
python-pytest-mock))
(home-page "https://www.dynaconf.com/")
(synopsis "The dynamic configurator for your Python project")