summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 82d297af3b..a37dc5e9e2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29393,7 +29393,11 @@ writing STL files. It supports both the text and binary forms of STL.")
(lambda _
(substitute* "setup.py"
(("test_suite = 'multipart.tests.suite'")
- "test_suite = 'multipart.tests.test_multipart.suite'")))))))
+ "test_suite = 'multipart.tests.test_multipart.suite'"))
+ ;; Needed by PyYAML 6.0.
+ (substitute* "multipart/tests/test_multipart.py"
+ (("yaml_data = yaml.load\\(f\\)")
+ "yaml_data = yaml.load(f, Loader=yaml.SafeLoader)")))))))
(home-page "https://github.com/andrew-d/python-multipart")
(synopsis "Streaming multipart parser for Python")
(description