summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5969384358..07a52a0e5c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14455,6 +14455,27 @@ builds partial trees by inspecting living objects.")
,@(alist-delete "python-typed-ast"
(package-propagated-inputs base)))))))
+(define-public python-isbnlib
+ (package
+ (name "python-isbnlib")
+ (version "3.10.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "isbnlib" version))
+ (sha256
+ (base32
+ "07qhykv0x60d5rsx5pj6s4q15ri4znczscll3xmpf6gyclac1592"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ; No test
+ (home-page "https://github.com/xlcnd/isbnlib")
+ (synopsis "Python library to work with ISBN strings")
+ (description "@code{python-isbnlib} is a (pure) python library that provides
+several useful methods and functions to validate, clean, transform, hyphenate and
+get metadata for ISBN strings. Its origin was as the core of isbntools. This short
+version, is suitable to be include as a dependency in other projects.")
+ (license license:lgpl3+)))
+
(define-public python-isort
(package
(name "python-isort")