summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 110d303818..cdc09bcc1b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1136,8 +1136,6 @@ multiple Unicode code points, e.g. \"G\" + acute-accent)
(arguments
`(;; XXX: Tests depend on coloredlogs, which in turn depends on humanfriendly.
#:tests? #f))
- (propagated-inputs
- `(("python-monotonic" ,python-monotonic)))
(home-page "https://humanfriendly.readthedocs.io")
(synopsis "Human-friendly input and output in Python")
(description
@@ -1146,10 +1144,16 @@ text interfaces more user-friendly. It includes tools to parse and format
numbers, file sizes, and timespans, timers for long-running operations, menus
to allow the user to choose from a list of options, and terminal interaction
helpers.")
+ (properties `((python2-variant . ,(delay python2-humanfriendly))))
(license license:expat)))
(define-public python2-humanfriendly
- (package-with-python2 python-humanfriendly))
+ (let ((base (package-with-python2
+ (strip-python2-variant python-humanfriendly))))
+ (package (inherit base)
+ (propagated-inputs
+ `(("python2-monotonic" ,python2-monotonic)
+ ,@(package-propagated-inputs base))))))
(define-public python-textparser
(package