summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9b651d2108..316549ecf1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13022,12 +13022,13 @@ with a new public API, and RPython support.")
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "python" "-m" "pytest" "-k"
- (string-append ; skip some failed tests
- "not test_bin_hy_sys_executable"
- " and not test_bin_hy_circular_macro_require"
- " and not test_macro_from_module")))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest" "-k"
+ (string-append ; skip some failed tests
+ "not test_bin_hy_sys_executable"
+ " and not test_bin_hy_circular_macro_require"
+ " and not test_macro_from_module"))))))))
(native-inputs
(list python-pytest))
(propagated-inputs