summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6ce8bd6402..e4cb94fe1b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5239,6 +5239,11 @@ matching of file paths.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'relax-version-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("tomli[^\"]*\",")
+ "tomli\","))))
(add-after 'patch-source-shebangs 'use-absolute-file-names
(lambda* (#:key native-inputs inputs #:allow-other-keys)
(let* ((inpts (or native-inputs inputs))