summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 04f53740e4..72d4eba0ff 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1352,6 +1352,22 @@ WebSocket usage in Python programs.")
than Python’s urllib2 library.")
(license license:asl2.0)))
+;; Some software requires an older version of Requests, notably Docker/Docker
+;; Compose.
+(define-public python-requests-2.20
+ (package (inherit python-requests)
+ (version "2.20.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "requests" version))
+ (sha256
+ (base32
+ "0qzj6cgv3k9wyj7wlxgz7xq0cfg4jbbkfm24pp8dnhczwl31527a"))))
+ (propagated-inputs
+ `(("python-urllib3" ,python-urllib3-1.24)
+ ("python-idna" ,python-idna-2.7)
+ ,@(package-propagated-inputs python-requests)))))
+
;; Some software requires an older version of Requests, notably Docker
;; Compose.
(define-public python-requests-2.7