summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a9f362e0bc..ed37e47448 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1122,7 +1122,13 @@ conforming to a given API or contract.")
"1nkgfwawswmyc6i0b8g3ymvja4mb507m8yhid8s4rbxq3dmqhwhd"))))
(build-system python-build-system)
(arguments
- '(#:tests? #f)) ; circular dependency with zope.testrunner
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "zope-testrunner" "--test-path=src"))))))
+ (native-inputs
+ `(("python-zope-testrunner" ,python-zope-testrunner-bootstrap)))
(propagated-inputs
`(("python-zope-interface" ,python-zope-interface)))
(home-page "https://pypi.org/project/zope.exceptions/")