summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm40
1 files changed, 31 insertions, 9 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 85c57e9f17..b7fc487bb5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2013, 2014, 2015, 2016, 2020 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2017, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2017, 2021 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017, 2020 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2014, 2017, 2021 Eric Bavier <bavier@posteo.net>
@@ -14,7 +14,7 @@
;;; Copyright © 2015 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2015, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015, 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
@@ -693,7 +693,8 @@ Swartz.")
(define-public python2-html2text
(let ((base (package-with-python2 python-html2text)))
- (package/inherit base
+ (package
+ (inherit base)
;; This is the last version with support for Python 2.
(version "2019.8.11")
(source (origin
@@ -1729,14 +1730,14 @@ web framework, either via the basic or digest authentication schemes.")
(define-public python-terminado
(package
(name "python-terminado")
- (version "0.9.4")
+ (version "0.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "terminado" version))
(sha256
(base32
- "1glqyw97rddyzvisz8rihsn3x2nrm5xbyq82nzp3123pqbxvqzcs"))))
+ "1smvra3sc9sg64w49kfn5yhagshq3x55839748ck5dvxvk4hgza6"))))
(build-system python-build-system)
(propagated-inputs
`(("python-tornado" ,python-tornado-6)
@@ -3886,7 +3887,7 @@ for Flask programs that are using @code{python-alembic}.")
(define-public python-genshi
(package
(name "python-genshi")
- (version "0.7.3")
+ (version "0.7.5")
(source
(origin
(method git-fetch)
@@ -3895,7 +3896,9 @@ for Flask programs that are using @code{python-alembic}.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "04bw7nd4wyn8ixnhik57hny2xpjjpn80k5hp6691inix5gc6rxaf"))))
+ (base32 "04i0caywiwrgw09grz988n15qr9lr31d9n6a529p8v80cy1fv23c"))))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
(build-system python-build-system)
(home-page "https://genshi.edgewall.org/")
(synopsis "Toolkit for generation of output for the web")
@@ -4254,6 +4257,25 @@ name resolutions asynchronously.")
for URL parsing and changing.")
(license license:asl2.0)))
+(define-public python-google
+ (package
+ (name "python-google")
+ (version "3.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "google" version))
+ (sha256
+ (base32
+ "1gncv3l11za0mpxvmpaf5n5j3jzp282rz62yml4ha4z55q930d8l"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; There are no tests.
+ (home-page "https://breakingcode.wordpress.com/")
+ (synopsis "Python bindings to the Google search engine")
+ (description "This package provides Python bindings for using the
+Google search engine. Its module is called @code{googlesearch}.")
+ (license license:bsd-3)))
+
(define-public python-google-api-client
(package
(name "python-google-api-client")
@@ -5460,13 +5482,13 @@ according to the standard set by PasteDeploy ")
(define-public python-hupper
(package
(name "python-hupper")
- (version "1.10.2")
+ (version "1.10.3")
(source (origin
(method url-fetch)
(uri (pypi-uri "hupper" version))
(sha256
(base32
- "0am0p6g5cz6xmcaf04xq8q6dzdd9qz0phj6gcmpsckf2mcyza61q"))))
+ "1nbc648d110jx6ziji980cdmzsd14p8fqrcarsdvr1vm5jvm2vyd"))))
(build-system python-build-system)
(arguments '(#:test-target "pytest"))
(native-inputs