summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c966710512..c04f2fbaf7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5928,14 +5928,14 @@ as a Python package.")
(define-public python-sanic
(package
(name "python-sanic")
- (version "20.12.2")
+ (version "20.12.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sanic" version))
(sha256
(base32
- "1c02gdp1j18xny9jd33fp0w57qqi7g66zwmaykv2dhcks96f5mxr"))))
+ "0axfc151s7nrykzypzciyvkxxrs5ayx8kxv4r620hjb9w3jjhfnp"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -5952,7 +5952,9 @@ as a Python package.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
(invoke "pytest" "-vv" "./tests" "-k"
- "not test_zero_downtime and not test_gunicorn_worker"))))))
+ (string-append "not test_zero_downtime "
+ "and not test_gunicorn_worker "
+ "and not test_logo_")))))))
(propagated-inputs
(list python-aiofiles
python-httptools