summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 406c6cb51b..6a3fc27353 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -741,21 +741,27 @@ other HTTP libraries.")
(define-public httpie
(package
(name "httpie")
- (version "2.3.0")
+ (version "3.0.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "httpie" version))
(sha256
(base32
- "15ngl3yc186gkgqdx8iav9bpj8gxjpzz26y32z92jwyhj4cmfh6m"))))
+ "16ay8mx2v1z3rywsszy055l5k50qjiwyc3pds5wxxzd1n9a79w97"))))
(build-system python-build-system)
(arguments
;; The tests attempt to access external web servers, so we cannot run them.
'(#:tests? #f))
(propagated-inputs
- (list python-colorama python-pygments python-requests
- python-requests-toolbelt))
+ (list python-colorama
+ python-pygments
+ python-requests
+ python-requests-toolbelt
+ python-pysocks
+ python-charset-normalizer
+ python-defusedxml
+ python-multidict))
(home-page "https://httpie.io")
(synopsis "cURL-like tool for humans")
(description