summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9110e9af21..947c200253 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -493,16 +493,8 @@ classes
@item Compatible with both CPython and PyPy
@item Cython support for better performance when used with CPython
@end itemize")
- (properties `((python2-variant . ,(delay python2-falcon))))
(license license:asl2.0)))
-(define-public python2-falcon
- (let ((falcon (package-with-python2 (strip-python2-variant python-falcon))))
- (package
- (inherit falcon)
- (native-inputs
- (alist-delete "python-rapidjson" (package-native-inputs falcon))))))
-
(define-public python-falcon-cors
(package
(name "python-falcon-cors")
@@ -526,9 +518,6 @@ CORS object to the incoming requests, enabling the ability to serve resources
over a different origin than that of the web application.")
(license license:asl2.0)))
-(define-public python2-falcon-cors
- (package-with-python2 python-falcon-cors))
-
(define-public python-furl
(package
(name "python-furl")
@@ -2508,17 +2497,8 @@ library.")
(description
"This module provides a building block to stub out the HTTP requests
portions of your testing code.")
- (properties `((python2-variant . ,(delay python2-requests-mock))))
(license license:asl2.0)))
-(define-public python2-requests-mock
- (package (inherit (package-with-python2
- (strip-python2-variant python-requests-mock)))
- (arguments
- `(#:python ,python-2
- ;; FIXME: 'subunit.run discover: error: no such option: --list'
- #:tests? #f))))
-
(define-public python-requests-toolbelt
(package
(name "python-requests-toolbelt")
@@ -3098,9 +3078,6 @@ concurrent HTTP client library for python using @code{gevent}.")
provide an easy-to-use Python interface for building OAuth1 and OAuth2 clients.")
(license license:isc)))
-(define-public python2-requests-oauthlib
- (package-with-python2 python-requests-oauthlib))
-
(define-public python-url
(package
(name "python-url")
@@ -3161,9 +3138,6 @@ provide an easy-to-use Python interface for building OAuth1 and OAuth2 clients."
@code{httplib2} for use with @code{requests} session objects.")
(license license:asl2.0)))
-(define-public python2-cachecontrol
- (package-with-python2 python-cachecontrol))
-
(define-public python-cachecontrol-0.11
(package
(inherit python-cachecontrol)