summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm40
1 files changed, 16 insertions, 24 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 708528983c..997b98e2a9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -689,7 +689,7 @@ other HTTP libraries.")
'(#:tests? #f))
(propagated-inputs
(list python-colorama python-pygments python-requests
- python-requests-toolbelt-0.9.1))
+ python-requests-toolbelt))
(home-page "https://httpie.io")
(synopsis "cURL-like tool for humans")
(description
@@ -2667,14 +2667,23 @@ portions of your testing code.")
(define-public python-requests-toolbelt
(package
(name "python-requests-toolbelt")
- (version "0.8.0")
+ (version "0.9.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "requests-toolbelt" version))
(sha256
(base32
- "1dc7l42i4080r8i4m9fj51jx367lqkai170vrv7wd93gdj9k39gn"))))
+ "1h3gm88dcjbd7gm229a7x5qkkhnsqsjz0m0l2xyavm2ab3a8k04n"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'delete-problematic-tests
+ (lambda _
+ ;; Fails because of expired certificate.
+ (delete-file "tests/test_x509_adapter.py")
+ ;; Fails due to networking (socket.gaierror: [Errno -2]
+ ;; Name or service not known).
+ (delete-file "tests/test_multipart_encoder.py"))))))
(native-inputs
(list python-betamax python-mock python-pytest))
(propagated-inputs
@@ -2682,26 +2691,9 @@ portions of your testing code.")
(synopsis "Extensions to python-requests")
(description "This is a toolbelt of useful classes and functions to be used
with python-requests.")
- (home-page "https://github.com/sigmavirus24/requests-toolbelt")
+ (home-page "https://github.com/requests/toolbelt/")
(license license:asl2.0)))
-(define-public python2-requests-toolbelt
- (package-with-python2 python-requests-toolbelt))
-
-(define-public python-requests-toolbelt-0.9.1
- (package
- (inherit python-requests-toolbelt)
- (version "0.9.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "requests-toolbelt" version))
- (sha256
- (base32
- "1h3gm88dcjbd7gm229a7x5qkkhnsqsjz0m0l2xyavm2ab3a8k04n"))))
- (arguments
- `(;; FIXME: Some tests require network access.
- #:tests? #f))))
-
(define-public python-requests-ftp
(package
(name "python-requests-ftp")
@@ -3223,7 +3215,7 @@ provide an easy-to-use Python interface for building OAuth1 and OAuth2 clients."
(define-public python-cachecontrol
(package
(name "python-cachecontrol")
- (version "0.12.5")
+ (version "0.12.10")
(source
(origin
(method git-fetch)
@@ -3234,7 +3226,7 @@ provide an easy-to-use Python interface for building OAuth1 and OAuth2 clients."
(file-name (git-file-name name version))
(sha256
(base32
- "03lgc65sl04n0cgzmmgg99bk83f9i6k8yrmcd4hpl46q1pymn0kz"))))
+ "0fviacb13h72l5c77p35lgr6kvlidfdb9xsicg3v6lblmp9cn2ws"))))
(build-system python-build-system)
(arguments
;; Versions > 0.11.6 depend on CherryPy for testing.
@@ -5960,7 +5952,7 @@ Encoding for HTTP.")
(list python-js2py
python-polling2
python-requests
- python-requests-toolbelt-0.9.1
+ python-requests-toolbelt
python-responses
python-pyparsing-2.4.7))
(native-inputs