summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm65
1 files changed, 64 insertions, 1 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 292f9dc11a..07d713e013 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
@@ -15,6 +15,8 @@
;;; Copyright © 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
+;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -373,6 +375,44 @@ genetic variation data.")
of the SGP4 satellite tracking algorithm.")
(license license:expat)))
+(define-public python-trimesh
+ (package
+ (name "python-trimesh")
+ (version "3.10.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trimesh" version))
+ (sha256
+ (base32 "0bw55cwxlxds0j54naijh64sdb0rkscx4i1fy0ql94h96kw2p2ir"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-numpy))
+ (native-inputs
+ (list python-coveralls
+ python-pyinstrument
+ python-pytest
+ python-pytest-cov))
+ (arguments
+ `(;; TODO: Get tests to work.
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-build
+ (lambda _
+ (substitute* "trimesh/resources/templates/blender_boolean.py"
+ (("\\$MESH_PRE")
+ "'$MESH_PRE'")))))))
+ (home-page "https://github.com/mikedh/trimesh")
+ (synopsis "Python library for loading and using triangular meshes")
+ (description
+ "Trimesh is a pure Python library for loading and using triangular meshes
+with an emphasis on watertight surfaces. The goal of the library is to provide
+a full featured and well tested Trimesh object which allows for easy
+manipulation and analysis, in the style of the Polygon object in the Shapely
+library.")
+ (license license:expat)))
+
(define-public python-pandas
(package
(name "python-pandas")
@@ -1120,3 +1160,26 @@ pandas notebooks, scripts, and libraries. Unlike other distributed DataFrame
libraries, Modin provides seamless integration and compatibility with existing
pandas code.")
(license license:asl2.0)))
+
+(define-public python-numpy-groupies
+ (package
+ (name "python-numpy-groupies")
+ (version "0.9.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "numpy_groupies" version))
+ (sha256
+ (base32 "000qz0z78rs3l6y0dd2vzvd2lx3mczm2762whwsdnhz6c35axdq1"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-pytest
+ python-pytest-runner
+ python-numba
+ python-numpy))
+ (home-page "https://github.com/ml31415/numpy-groupies")
+ (synopsis "Tools for group-indexing operations: aggregated sum and more")
+ (description
+ "This package provides optimized tools for group-indexing operations:
+aggregated sum and more.")
+ (license license:bsd-3)))