summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 8a15a2820b..3d6d4e909e 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -389,3 +389,28 @@ concise, and less error-prone developer experience. The package includes a
large and growing library of domain-agnostic functions for advanced analytics
and visualization with these data structures.")
(license license:asl2.0)))
+
+(define-public python-msgpack-numpy
+ (package
+ (name "python-msgpack-numpy")
+ (version "0.4.6.post0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "msgpack-numpy" version))
+ (sha256
+ (base32
+ "0syzy645mwcy7lfjwz6pc8f9p2vv1qk4limc8iina3l5nnf0rjyz"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-msgpack" ,python-msgpack)
+ ("python-numpy" ,python-numpy)))
+ (home-page "https://github.com/lebedov/msgpack-numpy")
+ (synopsis
+ "Numpy data serialization using msgpack")
+ (description
+ "This package provides encoding and decoding routines that enable the
+serialization and deserialization of numerical and array data types provided
+by numpy using the highly efficient @code{msgpack} format. Serialization of
+Python's native complex data types is also supported.")
+ (license license:bsd-3)))