summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm165
1 files changed, 120 insertions, 45 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 37beb5ed61..c0a1c4794f 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2020, 2021, 2022, 2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
@@ -158,6 +158,57 @@ the SciPy stack. It provides many user-friendly and efficient numerical
routines such as routines for numerical integration and optimization.")
(license license:bsd-3)))
+(define-public python-scikit-allel
+ (package
+ (name "python-scikit-allel")
+ (version "1.3.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "scikit-allel" version))
+ (sha256
+ (base32 "1vg88ng6gd175gzk39iz1drxig5l91dyx398w2kbw3w8036zv8gj"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ '(list "-k"
+ (string-append
+ ;; AttributeError: 'Dataset' object has no attribute 'asstr'
+ "not test_vcf_to_hdf5"
+ " and not test_vcf_to_hdf5_exclude"
+ " and not test_vcf_to_hdf5_rename"
+ " and not test_vcf_to_hdf5_group"
+ " and not test_vcf_to_hdf5_ann"
+ ;; Does not work with recent hmmlearn
+ " and not test_roh_mhmm_0pct"
+ " and not test_roh_mhmm_100pct"))
+ #:phases
+ '(modify-phases %standard-phases
+ (add-before 'check 'build-ext
+ (lambda _
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+ (propagated-inputs
+ (list python-dask
+ python-numpy))
+ (native-inputs
+ (list python-cython
+ ;; The following are all needed for the tests
+ htslib
+ python-h5py
+ python-hmmlearn
+ python-numexpr
+ python-pytest
+ python-scipy
+ python-setuptools-scm
+ python-zarr))
+ (home-page "https://github.com/cggh/scikit-allel")
+ (synopsis "Explore and analyze genetic variation data")
+ (description
+ "This package provides utilities for exploratory analysis of large scale
+genetic variation data.")
+ (license license:expat)))
+
(define-public python-scikit-fuzzy
(package
(name "python-scikit-fuzzy")
@@ -234,53 +285,33 @@ logic, also known as grey logic.")
"Scikit-image is a collection of algorithms for image processing.")
(license license:bsd-3)))
-(define-public python-scikit-allel
+(define-public python-scikit-optimize
(package
- (name "python-scikit-allel")
- (version "1.3.5")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "scikit-allel" version))
- (sha256
- (base32 "1vg88ng6gd175gzk39iz1drxig5l91dyx398w2kbw3w8036zv8gj"))))
- (build-system python-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "setup.py" "build_ext" "--inplace")
- (invoke "python" "-m" "pytest" "-v" "allel"
- ;; AttributeError: 'Dataset' object has no attribute 'asstr'
- "-k" (string-append
- "not test_vcf_to_hdf5"
- " and not test_vcf_to_hdf5_exclude"
- " and not test_vcf_to_hdf5_rename"
- " and not test_vcf_to_hdf5_group"
- " and not test_vcf_to_hdf5_ann"))))))))
+ (name "python-scikit-optimize")
+ (version "0.9.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "scikit-optimize" version))
+ (sha256
+ (base32
+ "0230ya8bwrzxjwcy2vz23a3hg6caggnnmg2vq1f9zz2797kckn3p"))))
+ (build-system pyproject-build-system)
(propagated-inputs
- (list python-dask
- python-numpy))
+ (list python-joblib
+ python-matplotlib
+ python-numpy
+ python-pyaml
+ python-scikit-learn
+ python-scipy))
(native-inputs
- (list python-cython
- ;; The following are all needed for the tests
- htslib
- python-h5py
- python-hmmlearn
- python-numexpr
- python-pytest
- python-scipy
- python-setuptools-scm
- python-zarr))
- (home-page "https://github.com/cggh/scikit-allel")
- (synopsis "Explore and analyze genetic variation data")
- (description
- "This package provides utilities for exploratory analysis of large scale
-genetic variation data.")
- (license license:expat)))
+ (list python-pytest))
+ (home-page "https://scikit-optimize.github.io/")
+ (synopsis "Sequential model-based optimization toolbox")
+ (description "Scikit-Optimize, or @code{skopt}, is a simple and efficient
+library to minimize (very) expensive and noisy black-box functions. It
+implements several methods for sequential model-based optimization.
+@code{skopt} aims to be accessible and easy to use in many contexts.")
+ (license license:bsd-3)))
(define-public python-trimesh
(package
@@ -1677,6 +1708,50 @@ Out-of-Core DataFrames (similar to Pandas), to visualize and explore big
tabular datasets. This package provides the core modules of Vaex.")
(license license:expat)))
+(define-public python-pylems
+ (package
+ (name "python-pylems")
+ (version "0.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyLEMS" version))
+ (sha256
+ (base32
+ "074azbyivjbwi61fs5p8z9n6d8nk8xw6fmln1www13z1dccb3740"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-lxml))
+ (home-page "https://github.com/LEMS/pylems")
+ (synopsis
+ "Python support for the Low Entropy Model Specification language (LEMS)")
+ (description
+ "A LEMS simulator written in Python which can be used to run
+NeuroML2 models.")
+ (license license:lgpl3)))
+
+(define-public python-libneuroml
+ (package
+ (name "python-libneuroml")
+ (version "0.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/NeuralEnsemble/libNeuroML.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mrm4rd6x1sm6hkvhk20mkqp9q53sl3lbvq6hqzyymkw1iqq6bhy"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-lxml python-six))
+ (native-inputs (list python-pytest python-numpy python-tables))
+ (home-page "https://libneuroml.readthedocs.org/en/latest/")
+ (synopsis
+ "Python library for working with NeuroML descriptions of neuronal models")
+ (description
+ "This package provides a Python library for working with NeuroML descriptions of
+neuronal models")
+ (license license:bsd-3)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar