summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm103
1 files changed, 102 insertions, 1 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 498f495584..e3d2da9b59 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -28,6 +28,7 @@
(define-module (gnu packages python-check)
#:use-module (gnu packages)
#:use-module (gnu packages check)
+ #:use-module (gnu packages openstack)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages web)
@@ -82,6 +83,39 @@ This package provides seamless integration with coverage.py (and thus pytest,
nosetests, etc...) in Python projects.")
(license license:expat)))
+(define-public python-junit-xml
+ ;; XXX: There are no tags or PyPI releases, so take the latest commit
+ ;; and use the version defined in setup.py.
+ (let ((version "1.9")
+ (commit "4bd08a272f059998cedf9b7779f944d49eba13a6")
+ (revision "0"))
+ (package
+ (name "python-junit-xml")
+ (version (git-version version revision commit))
+ (home-page "https://github.com/kyrus/python-junit-xml")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0b8kbjhk3j10rk0vcniy695m3h43yip6y93h1bd6jjh0cp7s09c7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (synopsis "Create JUnit XML test results")
+ (description
+ "This package provides a Python module for creating JUnit XML test
+result documents that can be read by tools such as Jenkins or Bamboo.")
+ (license license:expat))))
+
(define-public python-vcrpy
(package
(name "python-vcrpy")
@@ -436,6 +470,40 @@ in Pytest.")
of the project to ensure it renders properly.")
(license license:expat)))
+(define-public python-re-assert
+ (package
+ (name "python-re-assert")
+ (version "1.1.0")
+ (source
+ (origin
+ ;; There are no tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/asottile/re-assert")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rssq4wpqmx1c17hjfx5l3sn3zmnlz9jffddiqrs4f6h7m6cadai"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-covdefaults" ,python-covdefaults)
+ ("python-coverage" ,python-coverage)
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-regex" ,python-regex)))
+ (home-page "https://github.com/asottile/re-assert")
+ (synopsis "Show where your regex match assertion failed")
+ (description
+ "@code{re-assert} provides a helper class to make assertions of regexes
+simpler.")
+ (license license:expat)))
+
(define-public python-pytest-trio
(package
(name "python-pytest-trio")
@@ -868,7 +936,7 @@ variables in the @file{pytest.ini} file.")
`(#:tests? #f)) ;the mini test suite fails
(home-page "https://github.com/farizrahman4u/pyux")
(synopsis "Utility to check API integrity in Python libraries")
- (description "The pyux utility allows to detect API changes in Python
+ (description "The pyux utility detects API changes in Python
libraries.")
(license license:expat)))
@@ -1044,3 +1112,36 @@ any Python VM with basically no runtime overhead.")
(description "Robber is a Python assertion library for test-driven and
behavior-driven development (TDD and BDD).")
(license license:expat)))
+
+(define-public python-stestr
+ (package
+ (name "python-stestr")
+ (version "3.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "stestr" version))
+ (sha256
+ (base32
+ "0adhqp9c9338wlvlq776k57k04lyxp38bv591afdm9gjsn2qn1zm"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;to avoid circular dependencies
+ (native-inputs
+ `(("python-pbr" ,python-pbr)))
+ (propagated-inputs
+ `(("python-cliff" ,python-cliff)
+ ("python-fixtures" ,python-fixtures)
+ ("python-future" ,python-future)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-subunit" ,python-subunit)
+ ("python-testtools" ,python-testtools)
+ ("python-voluptuous" ,python-voluptuous)))
+ (home-page "https://stestr.readthedocs.io/en/latest/")
+ (synopsis "Parallel Python test runner")
+ (description "This package provides the @command{stestr} command, a
+parallel Python test runner built around @code{subunit}. It is designed to
+execute @code{unittest} test suites using multiple processes to split up
+execution of a test suite. It will also store a history of all test runs to
+help in debugging failures and optimizing the scheduler to improve speed.")
+ (license license:asl2.0)))