summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1071abdbad..0ab6aa8f47 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -360,6 +360,30 @@ framework.")
for the @code{pytest} framework.")
(license license:expat)))
+(define-public python-pytest-benchmark
+ (package
+ (name "python-pytest-benchmark")
+ (version "3.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-benchmark" version))
+ (sha256
+ (base32
+ "0a4mpb4j73dsyk47hd1prrjpfk4r458s102cn80rf253jg818hxd"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-py-cpuinfo" ,python-py-cpuinfo)))
+ (native-inputs
+ `(("python-pathlib2" ,python-pathlib2)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/ionelmc/pytest-benchmark")
+ (synopsis "Pytest fixture for benchmarking code")
+ (description
+ "This package provides a pytest fixture that will group the tests into
+rounds that are calibrated to the chosen timer.")
+ (license license:bsd-2)))
+
(define-public python-codacy-coverage
(package
(name "python-codacy-coverage")