summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm58
1 files changed, 56 insertions, 2 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index b4e2765d72..181aa8b05c 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -686,6 +686,31 @@ framework and makes it easy to undo any monkey patching. The fixtures are:
in Pytest.")
(license license:bsd-3)))
+(define-public python-pytest-pydocstyle
+ (package
+ (name "python-pytest-pydocstyle")
+ (version "2.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/henry0312/pytest-pydocstyle")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0w6fivz4nb4b70wzmi5sk17qs9pd05rnh03fmch6v00r3dmfpk39"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; test requires the package itself
+ (propagated-inputs
+ (list python-pydocstyle
+ python-pytest)) ;apparently required
+ (home-page "https://github.com/henry0312/pytest-pydocstyle")
+ (synopsis "Pytest plugin to run @command{pydocstyle}")
+ (description "This package provides a Pytest plugin to run
+@command{pydocstyle}.")
+ (license license:expat)))
+
(define-public python-covdefaults
(package
(name "python-covdefaults")
@@ -776,6 +801,35 @@ support and @code{subtests} fixture.")
"Plugin for managing VCR.py cassettes.")
(license license:expat))))
+(define-public python-pytest-doctest-custom
+ (package
+ (name "python-pytest-doctest-custom")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-doctest-custom" version))
+ (sha256
+ (base32 "0kxkdd6q9c3h31kc88lbyfll4c45b0zjd24cbr4c083fcvcy7lip"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "test_pytest_doctest_custom.py")))))))
+ (native-inputs
+ (list python-pytest))
+ (home-page "https://github.com/danilobellini/pytest-doctest-custom")
+ (synopsis
+ "Pytest plugin to customize string representations of doctest results")
+ (description "This package provides a Pytest plugin for customizing string
+representations of doctest results. It can change the display hook used by
+doctest to render the object representations.")
+ (license license:expat)))
+
(define-public python-pytest-checkdocs
(package
(name "python-pytest-checkdocs")
@@ -1020,14 +1074,14 @@ framework.")
(define-public python-pytest-pycodestyle
(package
(name "python-pytest-pycodestyle")
- (version "2.0.0") ;later versions require python-pytest~=5.4
+ (version "2.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-pycodestyle" version))
(sha256
(base32
- "02i5gl7pm9cwxk15sn29inz3n8flpj1r3p1l110h43f2na5w8h7z"))))
+ "1clyjypn93hwvz17f4i6n2688835d4y8qsq2aw17d6fkbqiy8mg7"))))
(build-system python-build-system)
(propagated-inputs
(list python-pycodestyle))