summaryrefslogtreecommitdiff
path: root/gnu/packages/pretty-print.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pretty-print.scm')
-rw-r--r--gnu/packages/pretty-print.scm28
1 files changed, 10 insertions, 18 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 728f00f16e..05960f6f48 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Meiyo Peng <meiyo@riseup.net>
;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
@@ -72,12 +72,9 @@
"a2ps-CVE-2015-8107.patch"))))
(build-system gnu-build-system)
(inputs
- `(("psutils" ,psutils)
- ("gv" ,gv)))
+ (list psutils gv))
(native-inputs
- `(("gperf" ,gperf)
- ("groff" ,groff)
- ("perl" ,perl)))
+ (list gperf groff perl))
(arguments
'(#:phases
(modify-phases %standard-phases
@@ -180,7 +177,7 @@ different programming languages.")
(arguments
'(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
(native-inputs
- `(("unzip" ,unzip)))
+ (list unzip))
(home-page "https://fmt.dev")
(synopsis "Small and fast C++ formatting library")
(description
@@ -228,8 +225,7 @@ to @code{IOStreams}.")
(let ((gcc (assoc-ref inputs "gcc")))
(setenv "CPLUS_INCLUDE_PATH"
(string-join
- (cons (string-append (assoc-ref inputs "libcxx")
- "/include/c++/v1")
+ (cons (search-input-directory inputs "/include/c++/v1")
;; Hide GCC's C++ headers so that they do not interfere with
;; the Clang headers.
(delete (string-append gcc "/include/c++")
@@ -241,7 +237,7 @@ to @code{IOStreams}.")
(getenv "CPLUS_INCLUDE_PATH"))))))))
(properties `((hidden? . #true)))
(native-inputs
- `(("unzip" ,unzip)))
+ (list unzip))
(inputs
`(("libcxx" ,libcxx+libcxxabi-6)
("libcxxabi" ,libcxxabi-6)
@@ -263,10 +259,9 @@ to @code{IOStreams}.")
;; The ctags that comes with emacs does not support the --excmd options,
;; so can't be used
(inputs
- `(("boost" ,boost)))
+ (list boost))
(native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)))
+ (list bison flex))
(arguments
`(#:configure-flags
(list (string-append "--with-boost="
@@ -359,12 +354,9 @@ seen in a terminal.")
(install-file "highlight.so" autodir))
#t))))))
(inputs
- `(("lua" ,lua)
- ("boost" ,boost)
- ("perl" ,perl)))
+ (list lua boost perl))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("swig" ,swig)))
+ (list pkg-config swig))
(home-page "http://www.andre-simon.de/doku/highlight/en/highlight.php")
(synopsis "Convert code to documents with syntax highlighting")
(description "Highlight converts source code to HTML, XHTML, RTF, LaTeX,