summaryrefslogtreecommitdiff
path: root/gnu/packages/plotutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/plotutils.scm')
-rw-r--r--gnu/packages/plotutils.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 0dcd6f7b88..4eb68c0270 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -61,9 +61,11 @@
;; that, libplot.la ends up containing just "-lXaw" (without
;; "-L/path/to/Xaw"), due to the fact that there is no
;; libXaw.la, which forces us to propagate libXaw.
- '(substitute* "configure"
- (("-lXaw")
- "-lXaw7")))))
+ '(begin
+ (substitute* "configure"
+ (("-lXaw")
+ "-lXaw7"))
+ #t))))
(build-system gnu-build-system)
(inputs `(("libpng" ,libpng)
("libx11" ,libx11)
@@ -98,7 +100,8 @@ scientific data.")
;; Use the standard location for modules.
(substitute* "Makefile.in"
(("godir = .*$")
- "godir = $(moddir)\n"))))))
+ "godir = $(moddir)\n"))
+ #t))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("guile" ,guile-2.2)))
@@ -124,9 +127,11 @@ using the Cairo drawing library.")
(modules '((guix build utils)))
(snippet
;; Install binaries in the right place.
- '(substitute* "src/Makefile"
- (("INSTALLBIN =.*$")
- (string-append "INSTALLBIN = $(out)/bin"))))))
+ '(begin
+ (substitute* "src/Makefile"
+ (("INSTALLBIN =.*$")
+ (string-append "INSTALLBIN = $(out)/bin")))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f