summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index ef2618083f..1c71c1f40f 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -60,7 +60,7 @@
(define-public php
(package
(name "php")
- (version "7.4.14")
+ (version "7.4.15")
(home-page "https://secure.php.net/")
(source (origin
(method url-fetch)
@@ -68,7 +68,7 @@
"php-" version ".tar.xz"))
(sha256
(base32
- "11i8w12kyz2lx3fs4vv4l6ccca1znmmdf7dv3mn01ngwd5ww7wzr"))
+ "1f1wsi2frdbr9a3hvhmk3mmd7cwzf6mwya2akpzkwyygy1jrr1cv"))
(modules '((guix build utils)))
(snippet
'(with-directory-excursion "ext"
@@ -183,12 +183,18 @@
"ext/calendar/tests/unixtojd_error1.phpt"
;; arm can be a lot slower, so a time-related test fails
"ext/fileinfo/tests/cve-2014-3538-nojit.phpt"
+ "ext/pcntl/tests/pcntl_unshare_01.phpt"
"ext/pcre/tests/bug76514.phpt"
"ext/pcre/tests/preg_match_error3.phpt"
+ "ext/pcre/tests/cache_limit.phpt"
+ "ext/sockets/tests/socket_getopt.phpt"
+ "ext/sockets/tests/socket_sendrecvmsg_error.phpt"
"ext/standard/tests/general_functions/var_export-locale.phpt"
"ext/standard/tests/general_functions/var_export_basic1.phpt"
"ext/intl/tests/timezone_getErrorCodeMessage_basic.phpt"
- "ext/intl/tests/timezone_getOffset_error.phpt")))
+ "ext/intl/tests/timezone_getOffset_error.phpt"
+ "sapi/cli/tests/cli_process_title_unix.phpt"
+ "sapi/cli/tests/upload_2G.phpt")))
'())
;; Drop tests that are known to fail.