summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm58
1 files changed, 51 insertions, 7 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d449abc78c..0d94566925 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Raoul J.P. Bonnal <ilpuccio.febo@gmail.com>
-;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2018, 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
;;; Copyright © 2017, 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
@@ -90,18 +90,17 @@
;; Yeah, Perl... It is required early in the bootstrap process by Linux.
(package
(name "perl")
- (version "5.30.2")
+ (version "5.32.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/src/5.0/perl-"
version ".tar.gz"))
(sha256
(base32
- "128nfdxcvxfn5kq55qcfrx2851ys8hv794dcdxbyny8rm7w7vnv6"))
+ "0b7brakq9xs4vavhg391as50nbhzryc7fy5i65r81bnq3j897dh3"))
(patches (search-patches
"perl-no-sys-dirs.patch"
"perl-autosplit-default-time.patch"
- "perl-deterministic-ordering.patch"
"perl-reproducible-build-date.patch"))))
(build-system gnu-build-system)
(arguments
@@ -5078,6 +5077,25 @@ vaguely inspired by John Ousterhout's Tk_ParseArgv.")
(home-page "https://metacpan.org/release/Getopt-Tabular")
(license (package-license perl))))
+(define-public perl-gettext
+ (package
+ (name "perl-gettext")
+ (version "1.07")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/P/PV/PVANDRY"
+ "/gettext-" version ".tar.gz"))
+ (sha256
+ (base32
+ "05cwqjxxary11di03gg3fm6j9lbvg1dr2wpr311c1rwp8salg7ch"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/gettext")
+ (synopsis "Perl bindings for POSIX i18n gettext functions")
+ (description
+ "Locale::gettext provides an object oriented interface to the
+internationalization functions provided by the C library.")
+ (license license:perl-license)))
+
(define-public perl-graph
(package
(name "perl-graph")
@@ -8572,13 +8590,39 @@ available.")
"01xifj83dv492lxixijmg6va02rf3ydlxly0a9slmx22r6qa1drh"))))
(build-system perl-build-system)
(propagated-inputs
- `(("perl-devel-symdump" ,perl-devel-symdump)))
+ `(("perl-devel-symdump" ,perl-devel-symdump)
+ ("perl-pod-parser" ,perl-pod-parser)))
(home-page "https://metacpan.org/release/Pod-Coverage")
(synopsis "Check for comprehensive documentation of a module")
(description "This module provides a mechanism for determining if the pod
for a given module is comprehensive.")
(license (package-license perl))))
+(define-public perl-pod-parser
+ (package
+ (name "perl-pod-parser")
+ (version "1.63")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MA/MAREKR/Pod-Parser-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1k8clxxdjag56zm6cv38c3q81gj7xphfhh98l21jynwp55hvbq6v"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Pod-Parser")
+ (synopsis "Modules for parsing/translating POD format documents")
+ (description
+ "@code{Pod::Parser} is a base class for creating POD filters and
+translators. It handles most of the effort involved with parsing the POD
+sections from an input stream, leaving subclasses free to be concerned only
+with performing the actual translation of text.
+
+@emph{NOTE}: This module is considered legacy. New projects should prefer
+@code{Pod::Simple} instead.")
+ (license license:perl-license)))
+
(define-public perl-pod-simple
(package
(name "perl-pod-simple")
@@ -11303,7 +11347,7 @@ MYMETA.yml.")
(define-public perl-module-build
(package
(name "perl-module-build")
- (version "0.4229")
+ (version "0.4231")
(source
(origin
(method url-fetch)
@@ -11311,7 +11355,7 @@ MYMETA.yml.")
"Module-Build-" version ".tar.gz"))
(sha256
(base32
- "064c03wxia7jz0i578awj4srykj0nnigm4p5r0dv0559rnk93r0z"))))
+ "05xpn8qg814y49vrih16zfr9iiwb7pmdf57ahjnc2h0p5illq3vy"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-cpan-meta" ,perl-cpan-meta)))