summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 040898b423..99a152e0ab 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -124,18 +124,16 @@
(modify-phases %standard-phases
(add-before 'configure 'setup-configure
(lambda* (#:key inputs #:allow-other-keys)
- (let ((coreutils (or (assoc-ref inputs "coreutils-minimal")
- (assoc-ref inputs "coreutils"))))
- ;; Use the right path for `pwd'.
- (substitute* "dist/PathTools/Cwd.pm"
- (("'/bin/pwd'")
- (string-append "'" coreutils "/bin/pwd'")))
-
- ;; Build in GNU89 mode to tolerate C++-style comment in libc's
- ;; <bits/string3.h>.
- (substitute* "cflags.SH"
- (("-std=c89")
- "-std=gnu89")))))
+ ;; Use the right path for `pwd'.
+ (substitute* "dist/PathTools/Cwd.pm"
+ (("'/bin/pwd'")
+ (string-append "'" (search-input-file inputs "bin/pwd") "'")))
+
+ ;; Build in GNU89 mode to tolerate C++-style comment in libc's
+ ;; <bits/string3.h>.
+ (substitute* "cflags.SH"
+ (("-std=c89")
+ "-std=gnu89"))))
,@(if (%current-target-system)
`((add-after 'unpack 'unpack-cross
(lambda* (#:key native-inputs inputs #:allow-other-keys)