summaryrefslogtreecommitdiff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index a1be996e04..89a761f0a7 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
+;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -364,6 +365,30 @@ modified or tested with this API, making it simple to test both individual
files, as well as to verify that there are no missing or unknown files.")
(license perl-license)))
+(define-public perl-test-distmanifest
+ (package
+ (name "perl-test-distmanifest")
+ (version "1.014")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/E/ET/ETHER/Test-DistManifest-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1ifpff5simjslabwy7ac6kdylv4c0b5b39fgpwf9ha16yh6w49ix"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (propagated-inputs
+ `(("perl-module-manifest" ,perl-module-manifest)))
+ (home-page "https://github.com/jawnsy/Test-DistManifest")
+ (synopsis "Author test that validates a package @file{MANIFEST}")
+ (description
+ "@code{Test::DistManifest} provides a simple method of testing that a
+@file{MANIFEST} file matches its distribution.")
+ (license perl-license)))
+
(define-public perl-test-eol
(package
(name "perl-test-eol")
@@ -1140,6 +1165,32 @@ a minimum of effort.")
;; "Under the same license as Perl itself"
(license perl-license)))
+(define-public perl-test-perltidy
+ (package
+ (name "perl-test-perltidy")
+ (version "20130104")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/L/LA/LARRYL/Test-PerlTidy-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1j5rsb4km9rzcbd1ljavj8vm42bmilji40v2jj2k87l1ykrxj59z"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-file-finder" ,perl-file-finder)
+ ("perl-file-slurp" ,perl-file-slurp)
+ ("perltidy" ,perltidy)
+ ("perl-text-diff" ,perl-text-diff)))
+ (home-page "http://search.cpan.org/dist/Test-PerlTidy/")
+ (synopsis "Check that all your Perl files are tidy")
+ (description
+ "Using @code{Test::PerlTidy}, any file ending in .pl, .pm, .t or .PL will
+cause a test fail unless it is exactly as @code{perltidy} would like it to be.")
+ (license perl-license)))
+
(define-public perl-test-trap
(package
(name "perl-test-trap")