summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm50
1 files changed, 38 insertions, 12 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index ca3a601826..a215fce034 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -5,12 +5,12 @@
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Nils Gillmann <ng0@n0.is>
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -124,6 +124,36 @@
(license license:gpl2+)
(home-page "https://poppler.freedesktop.org/")))
+(define-public poppler-data
+ (package
+ (name "poppler-data")
+ (version "0.4.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://poppler.freedesktop.org/poppler-data"
+ "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "04i0wgdkn5lhda8cyxd1ll4a2p41pwqrwd47n9mdpl7cx5ypx70z"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no test suite
+ #:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ ;; The package only provides some data files, so there is nothing to
+ ;; build.
+ (delete 'configure)
+ (delete 'build))))
+ (synopsis "Poppler encoding files for rendering of CJK and Cyrillic text")
+ (description "This package provides optional encoding files for Poppler.
+When present, Poppler is able to correctly render CJK and Cyrillic text.")
+ (home-page (package-home-page poppler))
+ ;; See COPYING in the source distribution for more information about
+ ;; the licensing.
+ (license (list license:bsd-3
+ license:gpl2))))
+
(define-public poppler-qt4
(package (inherit poppler)
(name "poppler-qt4")
@@ -567,19 +597,15 @@ extracting content or merging files.")
(define-public mupdf
(package
(name "mupdf")
- (version "1.12.0")
+ (version "1.13.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://mupdf.com/downloads/archive/"
name "-" version "-source.tar.xz"))
- (patches (search-patches "mupdf-build-with-latest-openjpeg.patch"
- "mupdf-CVE-2017-17858.patch"
- "mupdf-CVE-2018-6544.patch"
- "mupdf-CVE-2018-1000051.patch"))
(sha256
(base32
- "0b9j0gqbc3jhmx87r6idcsh8lnb30840c3hyx6dk2gdjqqh3hysp"))
+ "0129k92bav692l6lyw10ryldx7h2f9khjpgnp3f3n4fdsph9hrkl"))
(modules '((guix build utils)))
(snippet '(begin (delete-file-recursively "thirdparty") #t))))
(build-system gnu-build-system)
@@ -676,7 +702,7 @@ program capable of converting PDF into other formats.")
(define-public xournal
(package
(name "xournal")
- (version "0.4.8")
+ (version "0.4.8.2016")
(source
(origin
(method url-fetch)
@@ -684,7 +710,7 @@ program capable of converting PDF into other formats.")
"/xournal-" version ".tar.gz"))
(sha256
(base32
- "0c7gjcqhygiyp0ypaipdaxgkbivg6q45vhsj8v5jsi9nh6iqff13"))))
+ "09i88v3wacmx7f96dmq0l3afpyv95lh6jrx16xzm0jd1szdrhn5j"))))
(build-system gnu-build-system)
(inputs
`(("gtk" ,gtk+-2)
@@ -959,7 +985,7 @@ PDF. Indeed @command{pdfposter} was inspired by @command{poster}.")
(define-public pdfgrep
(package
(name "pdfgrep")
- (version "2.0.1")
+ (version "2.1.1")
(source
(origin
(method url-fetch)
@@ -967,7 +993,7 @@ PDF. Indeed @command{pdfposter} was inspired by @command{poster}.")
name "-" version ".tar.gz"))
(sha256
(base32
- "07llkrkcfjwd3ybai9ad10ybhr0biffcplmy7lw4fb87nd2dfw03"))))
+ "02qcl5kmr5qzjfc99qpbpfb1890bxlrq3r208gnding51zrmb09c"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))