summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm26
1 files changed, 19 insertions, 7 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 704093e16c..13808b003d 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -223,14 +224,14 @@ please install the @code{flyer-composer-gui} package.")))
(define-public poppler
(package
(name "poppler")
- (version "0.86.1")
+ (version "21.07.0")
(source (origin
(method url-fetch)
(uri (string-append "https://poppler.freedesktop.org/poppler-"
version ".tar.xz"))
(sha256
(base32
- "0v3z4mk1rr8i0c4cfkab7pnxdbil30j4cm4w6cqlq6cfghkhlqxg"))))
+ "1m54hsi8z6c13jdbjwz55flkra1mahmkw2igavbf8p86d2gv4sp2"))))
(build-system cmake-build-system)
;; FIXME:
;; use libcurl: no
@@ -256,14 +257,22 @@ please install the @code{flyer-composer-gui} package.")))
("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection)))
(arguments
- `(#:tests? #f ; no test data provided with the tarball
+ `(#:tests? #f ;no test data provided with the tarball
#:configure-flags
(let* ((out (assoc-ref %outputs "out"))
(lib (string-append out "/lib")))
(list "-DENABLE_UNSTABLE_API_ABI_HEADERS=ON" ;to install header files
"-DENABLE_ZLIB=ON"
+ "-DENABLE_BOOST=OFF" ;disable Boost to save size
(string-append "-DCMAKE_INSTALL_LIBDIR=" lib)
- (string-append "-DCMAKE_INSTALL_RPATH=" lib)))))
+ (string-append "-DCMAKE_INSTALL_RPATH=" lib)))
+ ,@(if (%current-target-system)
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-PKG_CONFIG
+ (lambda _
+ (setenv "PKG_CONFIG" ,(pkg-config-for-target))))))
+ '())))
(synopsis "PDF rendering library")
(description
"Poppler is a PDF rendering library based on the xpdf-3.0 code base.")
@@ -1135,10 +1144,14 @@ information for every pixel as the input.")
(substitute* "mk/Autoconf.mk"
(("/bin/echo") "echo")
(("/sbin/ldconfig -p") "echo lib")) #t))
+ (add-before 'build 'set-fcommon
+ (lambda _
+ (setenv "CFLAGS" "-fcommon")))
(delete 'configure))
#:tests? #f
- #:make-flags (list ,(string-append "CC=" (cc-for-target))
- (string-append "prefix=" (assoc-ref %outputs "out")))))
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "prefix=" (assoc-ref %outputs "out")))))
(inputs `(("libjpeg" ,libjpeg-turbo)
("curl" ,curl)
("libtiff" ,libtiff)
@@ -1160,7 +1173,6 @@ information for every pixel as the input.")
(description
"fbida contains a few applications for viewing and editing images on
the framebuffer.")
-
(license license:gpl2+)))
(define-public pdf2svg