summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 437000b7c0..689d03afc8 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -299,13 +299,6 @@ When present, Poppler is able to correctly render CJK and Cyrillic text.")
(license (list license:bsd-3
license:gpl2))))
-(define-public poppler-qt4
- (package/inherit poppler
- (name "poppler-qt4")
- (inputs `(("qt-4" ,qt-4)
- ,@(package-inputs poppler)))
- (synopsis "Qt4 frontend for the Poppler PDF rendering library")))
-
(define-public poppler-qt5
(package/inherit poppler
(name "poppler-qt5")
@@ -316,14 +309,14 @@ When present, Poppler is able to correctly render CJK and Cyrillic text.")
(define-public python-poppler-qt5
(package
(name "python-poppler-qt5")
- (version "0.24.2")
+ (version "21.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-poppler-qt5" version))
(sha256
(base32
- "0l69llw1fzwz8y90q0qp9q5pifbrqjjbwii7di54dwghw5fc6w1r"))))
+ "0b82gm4i75q5v19kfbq0h4y0b2vcwr2213zkhxh6l0h45kdndmxd"))))
(build-system python-build-system)
(arguments
`(;; There are no tests. The check phase just causes a rebuild.
@@ -346,7 +339,7 @@ When present, Poppler is able to correctly render CJK and Cyrillic text.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("python-sip" ,python-sip)
+ `(("python-sip" ,python-sip-4)
("python-pyqt" ,python-pyqt)
("poppler-qt5" ,poppler-qt5)
("qtbase" ,qtbase)))