summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm70
1 files changed, 66 insertions, 4 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 5a9d513336..820a879288 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -17,16 +17,21 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages pdf)
- #:use-module ((guix licenses) #:select (gpl2+))
+ #:use-module ((guix licenses)
+ #:renamer (symbol-prefix-proc 'license:))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages lesstif)
#:use-module (gnu packages libjpeg)
+ #:use-module (gnu packages libpng)
#:use-module (gnu packages libtiff)
- #:use-module (gnu packages pkg-config))
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages xorg))
(define-public poppler
(package
@@ -40,17 +45,74 @@
"1rmrspavldlpqi6g76fijcmshy80m0kxd01nc1dmy4id3h4las44"))))
(build-system gnu-build-system)
;; FIXME: more dependencies could be added
+ ;; cairo output: no (requires cairo >= 1.10.0)
+ ;; qt4 wrapper: no
+ ;; glib wrapper: no (requires cairo output)
+ ;; introspection: no
+ ;; use gtk-doc: no
+ ;; use libcurl: no
+ ;; use libopenjpeg: no
(inputs `(("fontconfig" ,fontconfig)
("freetype" ,freetype)
("libjpeg-8" ,libjpeg-8)
+ ("libpng" ,libpng)
("libtiff" ,libtiff)
("pkg-config" ,pkg-config)
("zlib" ,zlib)))
(arguments
`(#:tests? #f ; no test data provided with the tarball
- #:configure-flags '("--enable-xpdf-headers"))) ; to install header files
+ #:configure-flags
+ '("--enable-xpdf-headers" ; to install header files
+ "--enable-zlib")))
(synopsis "Poppler, a pdf rendering library")
(description
"Poppler is a PDF rendering library based on the xpdf-3.0 code base.")
- (license gpl2+)
+ (license license:gpl2+)
(home-page "http://poppler.freedesktop.org/")))
+
+(define-public xpdf
+ (package
+ (name "xpdf")
+ (version "3.03")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "ftp://ftp.foolabs.com/pub/xpdf/xpdf-"
+ version ".tar.gz"))
+ (sha256 (base32
+ "1jnfzdqc54wa73lw28kjv0m7120mksb0zkcn81jdlvijyvc67kq2"))))
+ (build-system gnu-build-system)
+ (inputs `(("freetype" ,freetype)
+ ("gs-fonts" ,gs-fonts)
+ ("lesstif" ,lesstif)
+ ("libpaper" ,libpaper)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxp" ,libxp)
+ ("libxpm" ,libxpm)
+ ("libxt" ,libxt)
+ ("zlib" ,zlib)
+ ("patch/constchar"
+ ,(search-patch "xpdf-constchar.patch"))))
+ (arguments
+ `(#:tests? #f ; there is no check target
+ #:patches (list (assoc-ref %build-inputs
+ "patch/constchar"))
+ #:phases
+ (alist-replace
+ 'install
+ (lambda* (#:key outputs inputs #:allow-other-keys #:rest args)
+ (let* ((install (assoc-ref %standard-phases 'install))
+ (out (assoc-ref outputs "out"))
+ (xpdfrc (string-append out "/etc/xpdfrc"))
+ (gs-fonts (assoc-ref inputs "gs-fonts")))
+ (apply install args)
+ (substitute* xpdfrc
+ (("/usr/local/share/ghostscript/fonts")
+ (string-append gs-fonts "/share/fonts/type1/ghostscript"))
+ (("#fontFile") "fontFile"))))
+ %standard-phases)))
+ (synopsis "Viewer for pdf files based on the Motif toolkit.")
+ (description
+ "Xpdf is a viewer for Portable Document Format (PDF) files")
+ (license license:gpl3) ; or gpl2, but not gpl2+
+ (home-page "http://www.foolabs.com/xpdf/")))