summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index d491642e49..3f329c5426 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -479,7 +479,7 @@ extracting content or merging files.")
(define-public mupdf
(package
(name "mupdf")
- (version "1.9a")
+ (version "1.10a")
(source
(origin
(method url-fetch)
@@ -487,18 +487,8 @@ extracting content or merging files.")
name "-" version "-source.tar.gz"))
(sha256
(base32
- "1k64pdapyj8a336jw3j61fhn0rp4q6az7d0dqp9r5n3d9rgwa5c0"))
- (patches (search-patches "mupdf-build-with-openjpeg-2.1.patch"
- "mupdf-CVE-2016-6265.patch"
- "mupdf-CVE-2016-6525.patch"
- "mupdf-CVE-2016-7504.patch"
- "mupdf-CVE-2016-7505.patch"
- "mupdf-CVE-2016-7506.patch"
- "mupdf-CVE-2016-7563.patch"
- "mupdf-CVE-2016-7564.patch"
- "mupdf-CVE-2016-8674.patch"
- "mupdf-CVE-2016-9017.patch"
- "mupdf-CVE-2016-9136.patch"))
+ "0dm8wcs8i29aibzkqkrn8kcnk4q0kd1v66pg48h5c3qqp4v1zk5a"))
+ (patches (search-patches "mupdf-build-with-openjpeg-2.1.patch"))
(modules '((guix build utils)))
(snippet
;; Delete all the bundled libraries except for mujs, which is