summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/emacs-helpful-fix-docstring-test.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/emacs-helpful-fix-docstring-test.patch b/gnu/packages/patches/emacs-helpful-fix-docstring-test.patch
new file mode 100644
index 0000000000..de40010fa2
--- /dev/null
+++ b/gnu/packages/patches/emacs-helpful-fix-docstring-test.patch
@@ -0,0 +1,18 @@
+This patch fixing a build failure has been cherry-picked from upstream.
+Originally submitted as pull request by Erik Šabič.
+See also <https://github.com/Wilfred/helpful/pull/296>.
+diff --git a/test/helpful-unit-test.el b/test/helpful-unit-test.el
+index a07aa8e..8a95129 100644
+--- a/test/helpful-unit-test.el
++++ b/test/helpful-unit-test.el
+@@ -119,7 +119,9 @@ bar")))
+ (should
+ (equal
+ (helpful--docstring #'test-foo-advised t)
+- "Docstring here too.")))
++ (if (version< emacs-version "28")
++ "Docstring here too."
++ "Docstring here too.\n\nThis function has :around advice: `ad-Advice-test-foo-advised'."))))
+
+ (defun test-foo-no-docstring ()
+ nil)