summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/emacs-exec-path.patch22
-rw-r--r--gnu/packages/patches/emacs-ignore-empty-xim-styles.patch4
-rw-r--r--gnu/packages/patches/emacs-source-date-epoch.patch6
-rw-r--r--gnu/packages/patches/emacs27-exec-path.patch18
4 files changed, 15 insertions, 35 deletions
diff --git a/gnu/packages/patches/emacs-exec-path.patch b/gnu/packages/patches/emacs-exec-path.patch
index 884fa94a64..7303599df1 100644
--- a/gnu/packages/patches/emacs-exec-path.patch
+++ b/gnu/packages/patches/emacs-exec-path.patch
@@ -4,15 +4,13 @@ with things like GCC being referenced.
--- a/lisp/loadup.el
+++ b/lisp/loadup.el
-@@ -64,6 +64,11 @@
- (expand-file-name "textmodes" dir)
- (expand-file-name "vc" dir)))))
-
-+;; Reset 'exec-path' so we don't capture the build-time $PATH in the
-+;; 'emacs' executable.
-+(setq-default exec-path nil)
-+(setq exec-path nil)
-+
- (if (eq t purify-flag)
- ;; Hash consing saved around 11% of pure space in my tests.
- (setq purify-flag (make-hash-table :test 'equal :size 70000)))
+@@ -481,7 +481,8 @@ lost after dumping")))
+ ((equal dump-mode "dump") "emacs")
+ ((equal dump-mode "bootstrap") "emacs")
+ ((equal dump-mode "pbootstrap") "bootstrap-emacs.pdmp")
+- (t (error "unrecognized dump mode %s" dump-mode)))))
++ (t (error "unrecognized dump mode %s" dump-mode))))
++ (exec-path nil))
+ (message "Dumping under the name %s" output)
+ (condition-case ()
+ (delete-file output)
diff --git a/gnu/packages/patches/emacs-ignore-empty-xim-styles.patch b/gnu/packages/patches/emacs-ignore-empty-xim-styles.patch
index 606d3ece6f..398e65bdc8 100644
--- a/gnu/packages/patches/emacs-ignore-empty-xim-styles.patch
+++ b/gnu/packages/patches/emacs-ignore-empty-xim-styles.patch
@@ -5,7 +5,7 @@ Index: emacs-26.3/src/xfns.c
===================================================================
--- emacs-26.3.orig/src/xfns.c
+++ emacs-26.3/src/xfns.c
-@@ -2533,6 +2533,8 @@ xic_free_xfontset (struct frame *f)
+@@ -2628,6 +2628,8 @@ xic_free_xfontset (struct frame *f)
static XIMStyle
best_xim_style (XIMStyles *xim)
{
@@ -14,7 +14,7 @@ Index: emacs-26.3/src/xfns.c
int i, j;
int nr_supported = ARRAYELTS (supported_xim_styles);
-@@ -2541,6 +2543,7 @@ best_xim_style (XIMStyles *xim)
+@@ -2636,6 +2638,7 @@ best_xim_style (XIMStyles *xim)
if (supported_xim_styles[i] == xim->supported_styles[j])
return supported_xim_styles[i];
diff --git a/gnu/packages/patches/emacs-source-date-epoch.patch b/gnu/packages/patches/emacs-source-date-epoch.patch
index 41c03ef514..77ea7ac15c 100644
--- a/gnu/packages/patches/emacs-source-date-epoch.patch
+++ b/gnu/packages/patches/emacs-source-date-epoch.patch
@@ -3,9 +3,9 @@ Honor SOURCE_DATE_EPOCH variable to avoid non-determinism in generated
--- a/lisp/emacs-lisp/autoload.el
+++ b/lisp/emacs-lisp/autoload.el
-@@ -378,8 +378,12 @@
- "Insert the section-header line,
- which lists the file name and which functions are in it, etc."
+@@ -419,8 +419,12 @@
+ ;; nil t))
+ ;; (match-end 2))))
(insert generate-autoload-section-header)
- (prin1 `(autoloads ,autoloads ,load-name ,file ,time)
- outbuf)
diff --git a/gnu/packages/patches/emacs27-exec-path.patch b/gnu/packages/patches/emacs27-exec-path.patch
deleted file mode 100644
index 418aa633a1..0000000000
--- a/gnu/packages/patches/emacs27-exec-path.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Do not capture the build-time value of $PATH in the 'emacs' executable
-since this can noticeably increase the size of the closure of Emacs
-with things like GCC being referenced.
-
-(like emacs-exec-path.patch, but for Emacs 27)
-
---- a/lisp/loadup.el
-+++ b/lisp/loadup.el
-@@ -479,7 +479,8 @@ lost after dumping")))
- ((equal dump-mode "dump") "emacs")
- ((equal dump-mode "bootstrap") "emacs")
- ((equal dump-mode "pbootstrap") "bootstrap-emacs.pdmp")
-- (t (error "unrecognized dump mode %s" dump-mode)))))
-+ (t (error "unrecognized dump mode %s" dump-mode))))
-+ (exec-path nil))
- (message "Dumping under the name %s" output)
- (condition-case ()
- (delete-file output)