summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/guile-ncurses-tests.patch15
-rw-r--r--gnu/packages/patches/icu4c-test-date-format.patch17
2 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/patches/guile-ncurses-tests.patch b/gnu/packages/patches/guile-ncurses-tests.patch
new file mode 100644
index 0000000000..483b05a4ef
--- /dev/null
+++ b/gnu/packages/patches/guile-ncurses-tests.patch
@@ -0,0 +1,15 @@
+The wide test files are missing from the tarball, so ignore them.
+Reported at <https://lists.gnu.org/archive/html/bug-guile-ncurses/2014-06/msg00000.html>.
+
+--- guile-ncurses-1.4/test/Makefile.in 2013-04-27 17:55:19.000000000 +0200
++++ guile-ncurses-1.4/test/Makefile.in 2014-06-16 21:39:40.000000000 +0200
+@@ -258,8 +258,7 @@ m011_menu_options.test slk_001_init.test
+ slk_003_init.test slk_004_init.test slk_005_demo.test \
+ slk_006_attributes.test
+
+-WIDETESTS = r037_border_set.test r038_get_wch.test r039_get_wstr.test \
+-r040_term_attrs.test
++WIDETESTS =
+
+ TESTS = $(NOTERMTESTS) $(am__append_1) $(am__append_2)
+ EXTRA_DIST = $(TESTLIB) $(TESTS)
diff --git a/gnu/packages/patches/icu4c-test-date-format.patch b/gnu/packages/patches/icu4c-test-date-format.patch
new file mode 100644
index 0000000000..d7f0df98a6
--- /dev/null
+++ b/gnu/packages/patches/icu4c-test-date-format.patch
@@ -0,0 +1,17 @@
+Starting with the switch to GCC 4.8.3, we observed this test failure.
+Changing "34" to "134" means that we expect the date to be parsed as
+"2034", not "1934", which seems consistent with the line above.
+
+Reported at <http://bugs.icu-project.org/trac/ticket/10960>.
+
+--- icu/source/test/intltest/dtfmttst.cpp 2014-06-16 10:35:46.000000000 +0200
++++ icu/source/test/intltest/dtfmttst.cpp 2014-06-16 10:35:52.000000000 +0200
+@@ -1129,7 +1129,7 @@ DateFormatTest::TestTwoDigitYear()
+ return;
+ }
+ parse2DigitYear(fmt, "5/6/17", date(117, UCAL_JUNE, 5));
+- parse2DigitYear(fmt, "4/6/34", date(34, UCAL_JUNE, 4));
++ parse2DigitYear(fmt, "4/6/34", date(134, UCAL_JUNE, 4));
+ }
+
+ // -------------------------------------