summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch36
-rw-r--r--gnu/packages/patches/lsh-guile-compat.patch9
-rw-r--r--gnu/packages/patches/lsh-no-root-login.patch16
-rw-r--r--gnu/packages/patches/lsh-pam-service-name.patch14
4 files changed, 36 insertions, 39 deletions
diff --git a/gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch b/gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch
new file mode 100644
index 0000000000..07d633149e
--- /dev/null
+++ b/gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch
@@ -0,0 +1,36 @@
+From b12040aeab5fbaf02677571db1d8bf1995bd5ee0 Mon Sep 17 00:00:00 2001
+From: Nikos Mavrogiannopoulos <nmav@gnutls.org>
+Date: Sun, 2 Jun 2013 12:10:06 +0200
+Subject: [PATCH] Avoid comparing the expiration date to prevent false positive
+error in 32-bit systems.
+
+---
+ tests/cert-tests/pem-decoding | 6 ++++--
+ 1 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/tests/cert-tests/pem-decoding b/tests/cert-tests/pem-decoding
+index fe769ec..f8c6372 100755
+--- tests/cert-tests/pem-decoding
++++ tests/cert-tests/pem-decoding
+@@ -61,7 +61,9 @@ if test "$rc" != "0"; then
+ exit $rc
+ fi
+
+-diff $srcdir/complex-cert.pem tmp-pem.pem
++cat $srcdir/complex-cert.pem |grep -v "Not After:" >tmp1
++cat $srcdir/tmp-pem.pem |grep -v "Not After:" >tmp2
++diff tmp1 tmp2
+ rc=$?
+
+ if test "$rc" != "0"; then
+@@ -69,6 +71,6 @@ if test "$rc" != "0"; then
+ exit $rc
+ fi
+
+-rm -f tmp-pem.pem
++rm -f tmp-pem.pem tmp1 tmp2
+
+ exit 0
+--
+1.7.1
+
diff --git a/gnu/packages/patches/lsh-guile-compat.patch b/gnu/packages/patches/lsh-guile-compat.patch
deleted file mode 100644
index 0fe0484580..0000000000
--- a/gnu/packages/patches/lsh-guile-compat.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-Use (ice-9 rdelim) for `read-line'.
-
---- lsh-2.0.4/src/scm/guile-compat.scm 2012-12-03 23:28:01.000000000 +0100
-+++ lsh-2.0.4/src/scm/guile-compat.scm 2012-12-03 23:28:04.000000000 +0100
-@@ -21,3 +21,4 @@
- ;; Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-
- (use-syntax (ice-9 syncase))
-+(use-modules (ice-9 rdelim))
diff --git a/gnu/packages/patches/lsh-no-root-login.patch b/gnu/packages/patches/lsh-no-root-login.patch
deleted file mode 100644
index 9dd81de3fb..0000000000
--- a/gnu/packages/patches/lsh-no-root-login.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Correctly handle the `--no-root-login' option.
-
---- lsh-2.0.4/src/lshd.c 2006-05-01 13:47:44.000000000 +0200
-+++ lsh-2.0.4/src/lshd.c 2009-09-08 12:20:36.000000000 +0200
-@@ -758,6 +758,10 @@ main_argp_parser(int key, char *arg, str
- self->allow_root = 1;
- break;
-
-+ case OPT_NO_ROOT_LOGIN:
-+ self->allow_root = 0;
-+ break;
-+
- case OPT_KERBEROS_PASSWD:
- self->pw_helper = PATH_KERBEROS_HELPER;
- break;
-
diff --git a/gnu/packages/patches/lsh-pam-service-name.patch b/gnu/packages/patches/lsh-pam-service-name.patch
deleted file mode 100644
index 6a6156855c..0000000000
--- a/gnu/packages/patches/lsh-pam-service-name.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Tell `lsh-pam-checkpw', the PAM password helper program, to use a more
-descriptive service name.
-
---- lsh-2.0.4/src/lsh-pam-checkpw.c 2003-02-16 22:30:10.000000000 +0100
-+++ lsh-2.0.4/src/lsh-pam-checkpw.c 2008-11-28 16:16:58.000000000 +0100
-@@ -38,7 +38,7 @@
- #include <security/pam_appl.h>
-
- #define PWD_MAXLEN 1024
--#define SERVICE_NAME "other"
-+#define SERVICE_NAME "lshd"
- #define TIMEOUT 600
-
- static int