summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/xgboost-use-system-dmlc-core.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/xgboost-use-system-dmlc-core.patch')
-rw-r--r--gnu/packages/patches/xgboost-use-system-dmlc-core.patch53
1 files changed, 27 insertions, 26 deletions
diff --git a/gnu/packages/patches/xgboost-use-system-dmlc-core.patch b/gnu/packages/patches/xgboost-use-system-dmlc-core.patch
index c654694fec..6b2a1651a5 100644
--- a/gnu/packages/patches/xgboost-use-system-dmlc-core.patch
+++ b/gnu/packages/patches/xgboost-use-system-dmlc-core.patch
@@ -1,34 +1,35 @@
-From 34167cc105e47589b86b6f62da76e0ab744002dd Mon Sep 17 00:00:00 2001
-From: Vinicius Monego <monego@posteo.net>
-Date: Tue, 11 May 2021 19:35:30 -0300
-Subject: [PATCH] Use dmlc-core from Guix.
-
----
-This patch is a subset of the following Debian patch: https://sources.debian.org/src/xgboost/1.2.1-1/debian/patches/cmake.patch/
-
-Rabit is now developed as part of xgboost, so we don't build it separately.
-
- CMakeLists.txt | 8 +++-----
- 1 file changed, 3 insertions(+), 5 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 6cc19fbd..3b42bc17 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -150,11 +150,9 @@ endif (USE_OPENMP)
+# This patch was imported from Debian: https://sources.debian.org/src/xgboost/1.5.1-1/debian/patches/cmake-dmlc-core.patch/
+Index: xgboost/CMakeLists.txt
+===================================================================
+--- xgboost.orig/CMakeLists.txt
++++ xgboost/CMakeLists.txt
+@@ -164,7 +164,9 @@ endif (USE_NCCL)
+
# dmlc-core
msvc_use_static_runtime()
-add_subdirectory(${xgboost_SOURCE_DIR}/dmlc-core)
--set_target_properties(dmlc PROPERTIES
-- CXX_STANDARD 14
-- CXX_STANDARD_REQUIRED ON
-- POSITION_INDEPENDENT_CODE ON)
+add_library(dmlc SHARED IMPORTED)
+find_library(DMLC_LIBRARY dmlc)
+set_property(TARGET dmlc PROPERTY IMPORTED_LOCATION "${DMLC_LIBRARY}")
+
if (MSVC)
- target_compile_options(dmlc PRIVATE
- -D_CRT_SECURE_NO_WARNINGS -D_CRT_SECURE_NO_DEPRECATE)
---
-2.31.1
+ if (TARGET dmlc_unit_tests)
+@@ -222,7 +224,7 @@ set_target_properties(runxgboost PROPERT
+ #-- End CLI for xgboost
+
+ # Common setup for all targets
+-foreach(target xgboost objxgboost dmlc runxgboost)
++foreach(target xgboost objxgboost runxgboost)
+ xgboost_target_properties(${target})
+ xgboost_target_link_libraries(${target})
+ xgboost_target_defs(${target})
+@@ -273,7 +275,7 @@ install(DIRECTORY ${xgboost_SOURCE_DIR}/
+ #
+ # https://github.com/dmlc/xgboost/issues/6085
+ if (BUILD_STATIC_LIB)
+- set(INSTALL_TARGETS xgboost runxgboost objxgboost dmlc)
++ set(INSTALL_TARGETS xgboost runxgboost objxgboost)
+ else (BUILD_STATIC_LIB)
+ set(INSTALL_TARGETS xgboost runxgboost)
+ endif (BUILD_STATIC_LIB)