summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/wget-CVE-2017-6508.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/wget-CVE-2017-6508.patch')
-rw-r--r--gnu/packages/patches/wget-CVE-2017-6508.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/patches/wget-CVE-2017-6508.patch b/gnu/packages/patches/wget-CVE-2017-6508.patch
new file mode 100644
index 0000000000..0218fceaad
--- /dev/null
+++ b/gnu/packages/patches/wget-CVE-2017-6508.patch
@@ -0,0 +1,45 @@
+Fix CVE-2017-6508:
+
+https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-6508
+
+Patch copied from upstream source repository:
+
+https://git.savannah.gnu.org/cgit/wget.git/commit/?id=4d729e322fae359a1aefaafec1144764a54e8ad4
+
+From 4d729e322fae359a1aefaafec1144764a54e8ad4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tim=20R=C3=BChsen?= <tim.ruehsen@gmx.de>
+Date: Mon, 6 Mar 2017 10:04:22 +0100
+Subject: [PATCH] Fix CRLF injection in Wget host part
+
+* src/url.c (url_parse): Reject control characters in host part of URL
+
+Reported-by: Orange Tsai
+---
+ src/url.c | 11 +++++++++++
+ 1 file changed, 11 insertions(+)
+
+diff --git a/src/url.c b/src/url.c
+index 8f8ff0b8..7d36b27d 100644
+--- a/src/url.c
++++ b/src/url.c
+@@ -925,6 +925,17 @@ url_parse (const char *url, int *error, struct iri *iri, bool percent_encode)
+ url_unescape (u->host);
+ host_modified = true;
+
++ /* check for invalid control characters in host name */
++ for (p = u->host; *p; p++)
++ {
++ if (c_iscntrl(*p))
++ {
++ url_free(u);
++ error_code = PE_INVALID_HOST_NAME;
++ goto error;
++ }
++ }
++
+ /* Apply IDNA regardless of iri->utf8_encode status */
+ if (opt.enable_iri && iri)
+ {
+--
+2.12.0
+